CVE-2025-64641: Mattermost Jira plugin crafted action leaks Jira issue details
Mattermost versions 11.1.x <= 11.1.0, 11.0.x <= 11.0.5, 10.12.x <= 10.12.3, 10.11.x <= 10.11.7 fail to verify that post actions invoking /share-issue-publicly were created by the Jira plugin which allowed a malicious Mattermost user to exfiltrate Jira tickets when victim users interacted with affected posts
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 11.1.1 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 11.0.6 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 10.12.4 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 10.11.8 - Upgrade
Upgrade
go/github.com/mattermost/mattermost/server/v8to a version that resolves this vulnerability.Fixed in 8.0.0-20251121122154-b57c297c6d7 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 11.2.0 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 11.1.1 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 11.0.6 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 10.12.4 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 10.11.8
Event History
Frequently Asked Questions
What is the severity of CVE-2025-64641?
CVE-2025-64641 is rated as a high-severity vulnerability due to the potential for unauthorized access to sensitive Jira tickets.
How do I fix CVE-2025-64641?
To fix CVE-2025-64641, upgrade Mattermost to versions 11.1.1, 11.0.6, 10.12.4, or 10.11.8 or later.
What versions of Mattermost are affected by CVE-2025-64641?
CVE-2025-64641 affects Mattermost versions 11.1.0, 11.0.5, 10.12.3, and 10.11.7 and earlier.
What is the nature of the vulnerability in CVE-2025-64641?
CVE-2025-64641 allows malicious users to exfiltrate Jira tickets due to improper verification of post actions from the Jira plugin.
Who is impacted by CVE-2025-64641?
Any Mattermost user who interacts with posts from the Jira plugin in affected versions is at risk from CVE-2025-64641.