CVE-2025-64715: Cilium with misconfigured toGroups in policies can lead to unrestricted egress traffic

Published Nov 29, 2025
·
Updated

Impact

CiliumNetworkPolicys which use egress.toGroups.aws.securityGroupsIds to reference AWS security group IDs that do not exist or are not attached to any network interface may unintentionally allow broader outbound access than intended by the policy authors. In such cases, the toCIDRset section of the derived policy is not generated, which means outbound traffic may be permitted to more destinations than originally intended.

Patches

This issue has been patched in:

Cilium v1.18.4 Cilium v1.17.10 Cilium v1.16.17

This issue affects:

- Cilium v1.18 between v1.18.0 and v1.18.3 inclusive - Cilium v1.17 between v1.17.0 and v1.17.9 inclusive - Cilium v1.16.16 and below

Workarounds

There is no workaround to this issue.

Acknowledgements

The Cilium community has worked together with members of Isovalent to prepare these mitigations. Special thanks to @SeanEmac for reporting this issue and to @fristonio for the patch.

For more information

If you think you have found a vulnerability affecting Cilium, we strongly encourage you to report it to our security mailing list at security@cilium.io. This is a private mailing list for the Cilium security team, and your report will be treated as top priority.

Other sources

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Prior to versions 1.16.17, 1.17.10, and 1.18.4, CiliumNetworkPolicys which use egress.toGroups.aws.securityGroupsIds to reference AWS security group IDs that do not exist or are not attached to any network interface may unintentionally allow broader outbound access than intended by the policy authors. In such cases, the toCIDRset section of the derived policy is not generated, which means outbound traffic may be permitted to more destinations than originally intended. This issue has been patched in versions 1.16.17, 1.17.10, and 1.18.4. There are no workarounds for this issue.

— MITRE

Affected Software

7 affected componentsFixes available
Cilium Cilium<1.16.17, <1.17.10, <1.18.4
go/github.com/cilium/cilium<1.16.17
1.16.17
go/ciliumgithub.com/cilium/cilium>=1.17.0<1.17.10
1.17.10
go/github.com/cilium/cilium>=1.18.0<1.18.4
1.18.4
Cilium Cilium<1.16.17
Cilium Cilium>=1.17.0<1.17.10
Cilium Cilium>=1.18.0<1.18.4

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade go/github.com/cilium/cilium to a version that resolves this vulnerability.

    Fixed in 1.16.17
  2. Upgrade

    Upgrade go/Ciliumgithub.com/cilium/cilium to a version that resolves this vulnerability.

    Fixed in 1.17.10
  3. Upgrade

    Upgrade go/github.com/cilium/cilium to a version that resolves this vulnerability.

    Fixed in 1.18.4
  4. Upgrade

    Upgrade Cilium to a version that resolves this vulnerability.

    Fixed in 1.16.17
  5. Upgrade

    Upgrade Cilium to a version that resolves this vulnerability.

    Fixed in 1.17.10
  6. Upgrade

    Upgrade Cilium to a version that resolves this vulnerability.

    Fixed in 1.18.4

Event History

Nov 29, 2025
CVE Published
via MITRE·12:11 AM
Data Sourced
via MITRE·12:11 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·01:16 AM
RemedyDescriptionSeverityWeaknessAffected Software
Dec 1, 2025
Advisory Published
via GitHub·06:59 PM
Data Sourced
via GitHub·06:59 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-64715?

The severity of CVE-2025-64715 has been assessed as medium due to potential unauthorized access through misconfigured AWS security groups.

2

How do I fix CVE-2025-64715?

To fix CVE-2025-64715, upgrade Cilium to versions 1.16.17, 1.17.10, or 1.18.4 or later.

3

What impacts does CVE-2025-64715 have on Cilium users?

CVE-2025-64715 can lead to improper network policy enforcement if referencing non-existent AWS security groups.

4

Are all versions of Cilium affected by CVE-2025-64715?

Yes, Cilium versions prior to 1.16.17, 1.17.10, and 1.18.4 are vulnerable to CVE-2025-64715.

5

What is the exposure risk associated with CVE-2025-64715?

The exposure risk associated with CVE-2025-64715 involves potential unauthorized network traffic due to misconfigured security group references.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203