CVE-2025-66215: OpenSC: Stack-buffer-overflow WRITE in card-oberthur

Published Mar 30, 2026
·
Updated

OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, an attacker with physical access to the computer at the time user or administrator uses a token can cause a stack-buffer-overflow WRITE in card-oberthur. The attack requires crafted USB device or smart card that would present the system with specially crafted responses to the APDUs. This issue has been patched in version 0.27.0.

Other sources

OpenSC: Stack-buffer-overflow WRITE in card-oberthur

— Microsoft

Affected Software

7 affected componentsFixes available
OpenSC OpenSC<0.27.0
Opensc Project Opensc<0.27.0
Microsoft azl3 opensc 0.26.1-1
All of the following
azurelinux/opensc<0.23.0-6
0.23.0-6
Microsoft CBL-Mariner=2.0
All of the following
azurelinux/opensc<0.27.1-1
0.27.1-1
Microsoft Azure Linux=3.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade azurelinux/opensc to a version that resolves this vulnerability.

    Fixed in 0.23.0-6
  2. Upgrade

    Upgrade azurelinux/opensc to a version that resolves this vulnerability.

    Fixed in 0.27.1-1
  3. Upgrade

    Upgrade OpenSC to a version that resolves this vulnerability.

    Fixed in 0.27.0

Event History

Mar 30, 2026
CVE Published
via MITRE·05:06 PM
Data Sourced
via MITRE·05:06 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·06:16 PM
RemedyDescriptionSeverityWeaknessAffected Software
Apr 1, 2026
Data Sourced
via Microsoft·08:13 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-66215?

CVE-2025-66215 has a high severity due to the potential for a stack-buffer-overflow, which can lead to system compromise.

2

How do I fix CVE-2025-66215?

To mitigate CVE-2025-66215, upgrade OpenSC to version 0.27.0 or later.

3

Who is affected by CVE-2025-66215?

CVE-2025-66215 affects users of OpenSC versions prior to 0.27.0 running on systems with physical access.

4

What consequences can arise from CVE-2025-66215?

Exploitation of CVE-2025-66215 can lead to unauthorized access and control over the affected system.

5

What kind of vulnerability is CVE-2025-66215?

CVE-2025-66215 is categorized as a stack-buffer-overflow vulnerability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203