CVE-2025-67303: High severity ComfyUI-Manager vulnerability
Impact
An Unprotected Alternate Channel (CWE-420) vulnerability was discovered in ComfyUI-Manager versions prior to 3.38.
Vulnerability Details
In affected versions, ComfyUI-Manager stored its configuration in the user/default/ComfyUI-Manager/ directory, which was accessible via ComfyUI's web APIs without proper access control. This unprotected alternate channel allowed remote attackers to read and manipulate configuration files and critical data through the web interface.
Potential Attack Scenarios
An attacker exploiting this vulnerability could: - Modify security settings: Lower the security level from "strong" to "weak" to enable more dangerous operations - Tamper with custom node sources: Add malicious custom node repositories - Manipulate snapshot data: Corrupt or alter system snapshots - Change manager behavior: Alter various manager configuration settings
Affected Configurations
| Configuration | Risk Level | |---------------|------------| | Systems running with --listen 0.0.0.0 (externally exposed) | HIGH | | Systems behind reverse proxy without proper access control | MEDIUM | | Local-only installations (default, localhost only) | NOT AFFECTED |
---
Patches
This issue has been patched in ComfyUI-Manager version 3.38.
Requirements
| Component | Minimum Version | Notes | |-----------|-----------------|-------| | ComfyUI | v0.3.76+ | Required for System User Protection API | | ComfyUI-Manager | v3.38+ | Contains the security fix |
What the Patch Does
1. Path Migration: Configuration files moved from unprotected user/default/ComfyUI-Manager/ to protected user/manager/ 2. Protected Directory: The new manager/ directory leverages ComfyUI's System User Protection API, which blocks external web API access 3. Security Level Enforcement: Settings below "normal" are automatically raised to "normal" during migration 4. Legacy Backup: Old data is backed up to .legacy-manager-backup/ with startup reminders until manually deleted 5. Fallback Protection: If ComfyUI < v0.3.76, Manager forces "strong" security mode, blocking new installations until ComfyUI is updated
Patch Details
- Commit: aaed1dc - Pull Request: ComfyUI-Manager/#2338 ComfyUI/#10966 - Changes: +780 lines, −61 lines across 13 files
---
Workarounds
If immediate upgrade is not possible, apply the following mitigations:
| Mitigation | Effectiveness | Effort | |------------|---------------|--------| | Remove --listen 0.0.0.0 flag (use localhost only) | HIGH | Low | | Implement firewall rules to block external access to ComfyUI ports | HIGH | Medium | | Use reverse proxy with authentication (e.g., nginx + basic auth) | HIGH | Medium | | Restrict network access to trusted IPs only | MEDIUM | Low |
Note: These are temporary mitigations. Upgrading to v3.38+ is strongly recommended.
---
Resources
- NVD - CVE-2025-67303 - ComfyUI-Manager v3.38 Security Migration Guide - Patch Pull Request ComfyUI-Manager/#2338 - Patch Pull Request ComfyUI/#10966
---
Credit
This vulnerability was reported by Ricter Zheng (ricterzheng / 郑杜涛) from Tencent Xuanwu Lab <ricterzheng@tencent.com>
Other sources
An issue in ComfyUI-Manager prior to version 3.38 allowed remote attackers to potentially manipulate its configuration and critical data. This was due to the application storing its files in an insufficiently protected location that was accessible via the web interface
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
pip/comfyui-managerto a version that resolves this vulnerability.Fixed in 3.38 - Upgrade
Upgrade
ComfyUI-Managerto a version that resolves this vulnerability.Fixed in 3.38 - Upgrade
Upgrade
ComfyUIto a version that resolves this vulnerability.Fixed in 0.3.76 - Configuration
Remove the --listen 0.0.0.0 flag and run ComfyUI on localhost only.
ComfyUI --listen = localhost only - Compensating control
Implement firewall rules to block external access to ComfyUI ports.
- Compensating control
Use a reverse proxy with authentication, such as nginx with basic authentication, for ComfyUI access.
Event History
Frequently Asked Questions
What is the severity of CVE-2025-67303?
CVE-2025-67303 is classified as a medium severity vulnerability due to remote configuration manipulation risks.
How do I fix CVE-2025-67303?
To fix CVE-2025-67303, upgrade your ComfyUI-Manager to version 3.38 or later.
What versions of ComfyUI-Manager are affected by CVE-2025-67303?
CVE-2025-67303 affects ComfyUI-Manager versions prior to 3.38.
What type of vulnerability is CVE-2025-67303?
CVE-2025-67303 is a remote configuration manipulation vulnerability.
Can CVE-2025-67303 be exploited remotely?
Yes, CVE-2025-67303 can be exploited remotely by attackers to manipulate configuration and critical data.