CVE-2025-71112: net: hns3: add VLAN id validation before using

Published Jan 14, 2026
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

net: hns3: add VLAN id validation before using

Currently, the VLAN id may be used without validation when receive a VLAN configuration mailbox from VF. The length of vlandelfailbmap is BITSTOLONGS(VLANNVID). It may cause out-of-bounds memory access once the VLAN id is bigger than or equal to VLANNVID.

Therefore, VLAN id needs to be checked to ensure it is within the range of VLANNVID.

Affected Software

17 affected componentsFixes available
Linux Linux kernel
Linux Linux kernel>=5.3.1<5.10.248
Linux Linux kernel>=5.11<5.15.198
Linux Linux kernel>=5.16<6.1.160
Linux Linux kernel>=6.2<6.6.120
Linux Linux kernel>=6.7<6.12.64
Linux Linux kernel>=6.13<6.18.3
Linux Linux kernel=5.3
Linux Linux kernel=6.19-rc1
Linux Linux kernel=6.19-rc2
Linux Linux kernel=6.19-rc3
Linux Linux kernel=6.19-rc4
Linux Linux kernel=6.19-rc5
Linux Linux kernel=6.19-rc6
Linux Linux kernel=6.19-rc7
Linux Linux kernel=6.19-rc8
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    Validate the VLAN ID before using it when processing a VLAN configuration mailbox from a VF, ensuring it is within the range of VLAN_N_VID (less than VLAN_N_VID) to prevent out-of-bounds access to vlan_del_fail_bmap.

Event History

Jan 14, 2026
CVE Published
via MITRE·03:05 PM
Data Sourced
via MITRE·03:05 PM
DescriptionSeverity
Data Sourced
via NVD·03:16 PM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-71112?

CVE-2025-71112 is classified as a medium severity vulnerability due to its potential impact on VLAN configuration integrity.

2

How do I fix CVE-2025-71112?

To fix CVE-2025-71112, ensure that you update your Linux kernel to the latest version that includes the VLAN ID validation improvements.

3

What conditions are required for CVE-2025-71112 to be exploited?

CVE-2025-71112 can be exploited when an attacker sends a malicious VLAN configuration mailbox to a vulnerable virtual function.

4

Which systems are affected by CVE-2025-71112?

CVE-2025-71112 affects systems running vulnerable versions of the Linux kernel that do not implement proper VLAN ID validation.

5

What is the impact of CVE-2025-71112 on network security?

The impact of CVE-2025-71112 on network security includes the potential for unauthorized access and manipulation of VLAN configurations.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203