CVE-2025-71143: clk: samsung: exynos-clkout: Assign .num before accessing .hws

Published Jan 14, 2026
·
Updated

clk: samsung: exynos-clkout: Assign .num before accessing .hws

Affected Software

14 affected componentsFixes available
Linux Linux kernel
Linux Linux kernel>=6.6.1<6.6.120
Linux Linux kernel>=6.7<6.12.64
Linux Linux kernel>=6.13<6.18.4
Linux Linux kernel=6.6
Linux Linux kernel=6.19-rc1
Linux Linux kernel=6.19-rc2
Linux Linux kernel=6.19-rc3
Linux Linux kernel=6.19-rc4
Linux Linux kernel=6.19-rc5
Linux Linux kernel=6.19-rc6
Linux Linux kernel=6.19-rc7
Linux Linux kernel=6.19-rc8
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    In exynos_clkout_probe(), initialize the .num member of struct clk_hw_onecell_data with the number of elements before the first access to the .hws[] array.

Event History

Jan 14, 2026
CVE Published
via MITRE·03:07 PM
Data Sourced
via MITRE·03:07 PM
Description
Data Sourced
via NVD·03:16 PM
RemedyDescriptionSeverityWeaknessAffected Software
Jan 16, 2026
Data Sourced
via Microsoft·09:02 AM
DescriptionSeverityWeakness

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-71143?

The severity of CVE-2025-71143 is classified as medium due to its potential impact on system stability.

2

How do I fix CVE-2025-71143?

To fix CVE-2025-71143, you should update your Linux kernel to a version that includes the patch for this vulnerability.

3

Which versions of the Linux kernel are affected by CVE-2025-71143?

CVE-2025-71143 affects various versions of the Linux kernel prior to the implementation of the fix in the commit.

4

What type of vulnerability is CVE-2025-71143?

CVE-2025-71143 is a coding error vulnerability related to improper handling of the clk_hw structure in the Linux kernel.

5

Is CVE-2025-71143 a local or remote vulnerability?

CVE-2025-71143 is primarily a local vulnerability that can be exploited by an attacker with local access to the system.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203