CVE-2025-71222: wifi: wlcore: ensure skb headroom before skb_push

Published Feb 14, 2026
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

wifi: wlcore: ensure skb headroom before skbpush

This avoids occasional skbunderpanic Oops from wl1271txwork. In this case, headroom is less than needed (typically 110 - 94 = 16 bytes).

Affected Software

10 affected componentsFixes available
Linux Linux kernel>=2.6.32<5.10.250
Linux Linux kernel>=5.11<5.15.200
Linux Linux kernel>=5.16<6.1.163
Linux Linux kernel>=6.2<6.6.124
Linux Linux kernel>=6.7<6.12.70
Linux Linux kernel>=6.13<6.18.10
Linux Linux kernel=6.19-rc1
Linux Linux kernel=6.19-rc2
Linux Linux kernel=6.19-rc3
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Feb 14, 2026
CVE Published
via MITRE·04:27 PM
Data Sourced
via MITRE·04:27 PM
Description
Data Sourced
via NVD·05:15 PM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-71222?

CVE-2025-71222 is classified with a severity level that may impact system stability due to skb_under_panic errors.

2

How do I fix CVE-2025-71222?

To fix CVE-2025-71222, upgrade your Linux kernel to a version that addresses this vulnerability.

3

Which versions of the Linux kernel are affected by CVE-2025-71222?

CVE-2025-71222 affects various versions of the Linux kernel from 2.6.32 to 6.19-rc3.

4

What are the potential impacts of CVE-2025-71222?

The potential impacts of CVE-2025-71222 include system crashes or instability due to skb_under_panic errors.

5

Is CVE-2025-71222 related to specific hardware?

CVE-2025-71222 primarily affects the wlcore driver in the Linux kernel, which is related to specific Wi-Fi hardware.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203