CVE-2025-71236: scsi: qla2xxx: Validate sp before freeing associated memory

Published Feb 18, 2026
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

scsi: qla2xxx: Validate sp before freeing associated memory

System crash with the following signature [154563.214890] nvme nvme2: NVME-FC{1}: controller connect complete [154564.169363] qla2xxx [0000:b0:00.1]-3002:2: nvme: Sched: Set ZIO exchange threshold to 3. [154564.169405] qla2xxx [0000:b0:00.1]-ffffff:2: SET ZIO Activity exchange threshold to 5. [154565.539974] qla2xxx [0000:b0:00.1]-5013:2: RSCN database changed – 0078 0080 0000. [154565.545744] qla2xxx [0000:b0:00.1]-5013:2: RSCN database changed – 0078 00a0 0000. [154565.545857] qla2xxx [0000:b0:00.1]-11a2:2: FEC=enabled (data rate). [154565.552760] qla2xxx [0000:b0:00.1]-11a2:2: FEC=enabled (data rate). [154565.553079] BUG: kernel NULL pointer dereference, address: 00000000000000f8 [154565.553080] #PF: supervisor read access in kernel mode [154565.553082] #PF: errorcode(0x0000) - not-present page [154565.553084] PGD 80000010488ab067 P4D 80000010488ab067 PUD 104978a067 PMD 0 [154565.553089] Oops: 0000 1 PREEMPT SMP PTI [154565.553092] CPU: 10 PID: 858 Comm: qla2xxx2dpc Kdump: loaded Tainted: G OE ------- --- 5.14.0-503.11.1.el95.x8664 #1 [154565.553096] Hardware name: HPE Synergy 660 Gen10/Synergy 660 Gen10 Compute Module, BIOS I43 09/30/2024 [154565.553097] RIP: 0010:qlafabasyncscan.part.0+0x40b/0x870 [qla2xxx] [154565.553141] Code: 00 00 e8 58 a3 ec d4 49 89 e9 ba 12 20 00 00 4c 89 e6 49 c7 c0 00 ee a8 c0 48 c7 c1 66 c0 a9 c0 bf 00 80 00 10 e8 15 69 00 00 <4c> 8b 8d f8 00 00 00 4d 85 c9 74 35 49 8b 84 24 00 19 00 00 48 8b [154565.553143] RSP: 0018:ffffb4dbc8aebdd0 EFLAGS: 00010286 [154565.553145] RAX: 0000000000000000 RBX: ffff8ec2cf0908d0 RCX: 0000000000000002 [154565.553147] RDX: 0000000000000000 RSI: ffffffffc0a9c896 RDI: ffffb4dbc8aebd47 [154565.553148] RBP: 0000000000000000 R08: ffffb4dbc8aebd45 R09: 0000000000ffff0a [154565.553150] R10: 0000000000000000 R11: 000000000000000f R12: ffff8ec2cf0908d0 [154565.553151] R13: ffff8ec2cf090900 R14: 0000000000000102 R15: ffff8ec2cf084000 [154565.553152] FS: 0000000000000000(0000) GS:ffff8ed27f800000(0000) knlGS:0000000000000000 [154565.553154] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033 [154565.553155] CR2: 00000000000000f8 CR3: 000000113ae0a005 CR4: 00000000007706f0 [154565.553157] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000 [154565.553158] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400 [154565.553159] PKRU: 55555554 [154565.553160] Call Trace: [154565.553162] <TASK> [154565.553165] ? showtraceloglvl+0x1c4/0x2df [154565.553172] ? showtraceloglvl+0x1c4/0x2df [154565.553177] ? qlafabasyncscan.part.0+0x40b/0x870 [qla2xxx] [154565.553215] ? diebody.cold+0x8/0xd [154565.553218] ? pagefaultoops+0x134/0x170 [154565.553223] ? snprintf+0x49/0x70 [154565.553229] ? excpagefault+0x62/0x150 [154565.553238] ? asmexcpagefault+0x22/0x30

Check for sp being non NULL before freeing any associated memory

Affected Software

10 affected componentsFixes available
Linux Linux kernel
Microsoft cbl2 kernel 5.15.200.1-1
Linux Linux kernel>=4.16<5.10.251
Linux Linux kernel>=5.11<5.15.201
Linux Linux kernel>=5.16<6.1.164
Linux Linux kernel>=6.2<6.6.125
Linux Linux kernel>=6.7<6.12.72
Linux Linux kernel>=6.13<6.18.11
Linux Linux kernel>=6.19<6.19.1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    In the Linux kernel scsi: qla2xxx driver, validate that sp is non-NULL before freeing any associated memory.

Event History

Feb 18, 2026
CVE Published
via MITRE·02:53 PM
Data Sourced
via MITRE·02:53 PM
DescriptionSeverity
Data Sourced
via NVD·04:22 PM
RemedyDescriptionSeverityWeaknessAffected Software
Feb 21, 2026
Data Sourced
via Microsoft·12:29 PM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-71236?

The severity of CVE-2025-71236 is categorized as high due to the potential to cause system crashes.

2

How do I fix CVE-2025-71236?

To fix CVE-2025-71236, update your Linux kernel to the latest version that includes the patch for this vulnerability.

3

What systems are affected by CVE-2025-71236?

CVE-2025-71236 affects specific versions of the Linux kernel that use the qla2xxx SCSI driver.

4

Can CVE-2025-71236 be exploited remotely?

CVE-2025-71236 is primarily a local vulnerability but could lead to remote exploitation under specific conditions.

5

What symptoms indicate the presence of CVE-2025-71236?

Symptoms of CVE-2025-71236 may include system crashes, specifically showing signatures related to NVME controller operations.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203