CVE-2025-8879: High Heap buffer overflow in libaom
Chromium: CVE-2025-8879 Heap buffer overflow in libaom
Other sources
Heap buffer overflow in libaom in Google Chrome prior to 139.0.7258.127 allowed a remote attacker to potentially exploit heap corruption via a curated set of gestures. (Chromium security severity: High)
— MITRE
This CVE was assigned by Chrome. Microsoft Edge (Chromium-based) ingests Chromium, which addresses this vulnerability. Please see Google Chrome Releases for more information.
— Microsoft
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.73-1 - Upgrade
Upgrade
Chromiumto a version that resolves this vulnerability.Fixed in 139.0.7258.127
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2025-8879?
CVE-2025-8879 has a high severity level due to the potential for remote attackers to exploit heap corruption.
How do I fix CVE-2025-8879?
To fix CVE-2025-8879, users should update Google Chrome to version 139.0.7258.127 or later.
What is the impact of CVE-2025-8879 on my system?
CVE-2025-8879 could allow a remote attacker to execute arbitrary code by exploiting a heap buffer overflow.
Which versions of Google Chrome are affected by CVE-2025-8879?
CVE-2025-8879 affects all versions of Google Chrome prior to 139.0.7258.127.
Who is affected by CVE-2025-8879?
Any user of Google Chrome versions before 139.0.7258.127 is potentially affected by CVE-2025-8879.