CVE-2025-9958: Information disclosure issue in virtual registry configuration for low privileged users impacts GitLab CE/EE

Published Sep 25, 2025
·
Updated

An issue has been discovered in GitLab CE/EE affecting all versions from 14.10 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1, that could have allowed Guest users to access sensitive information stored in virtual registry configurations.

Other sources

GitLab has remediated an issue that could have allowed low privileged users access to sensitive information stored in virtual registry configurations.

— GitLab

Affected Software

8 affected componentsFixes available
GitLab GitLab CE/EE>=14.10, <18.2.7, >=18.3, <18.3.3, >=18.4, <18.4.1
GitLab GitLab>=14.10.0<18.2.7
GitLab GitLab>=14.10.0<18.2.7
GitLab GitLab>=18.3.0<18.3.3
GitLab GitLab>=18.3.0<18.3.3
GitLab GitLab=18.4.0
GitLab GitLab=18.4.0
GitLab GitLab>=14.10<18.2.7, >=18.3<18.3.3, >=18.4<18.4.1
18.2.718.3.318.4.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 18.2.7Fixed in 18.3.3Fixed in 18.4.1
  2. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 18.2.7
  3. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 18.3.3
  4. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 18.4.1

Event History

Sep 26, 2025
CVE Published
via MITRE·09:04 AM
Data Sourced
via MITRE·09:04 AM
RemedyDescriptionSeverityWeakness
Data Sourced
via OSV·09:04 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·09:15 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-9958?

CVE-2025-9958 is considered a high-severity vulnerability as it allows Guest users to access sensitive information.

2

How do I fix CVE-2025-9958?

To fix CVE-2025-9958, upgrade your GitLab CE/EE installation to version 18.2.7, 18.3.3, or 18.4.1 or newer.

3

Who is affected by CVE-2025-9958?

CVE-2025-9958 affects all users of GitLab CE/EE versions from 14.10 up to but not including 18.2.7, 18.3 up to but not including 18.3.3, and 18.4 up to but not including 18.4.1.

4

What type of information can Guest users access due to CVE-2025-9958?

Due to CVE-2025-9958, Guest users could potentially access sensitive information stored in virtual registry configurations.

5

Is there a workaround for CVE-2025-9958?

There is no recommended workaround for CVE-2025-9958; upgrading to a patched version is the only solution.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203