CVE-2026-103360: Langflow OSS is affected by multiple vulnerabilities
IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated attacker to obtain sensitive information due to improper limitation of a pathname to a restricted directory.
Other sources
Langflow OSS could allow a remote authenticated attacker to obtain sensitive information due to improper limitation of a pathname to a restricted directory.
— IBM
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
IBM Langflow OSSto a version that resolves this vulnerability.Fixed in 1.12.3
Event History
Frequently Asked Questions
Which deployments are affected?
IBM Langflow OSS versions 1.0.0 through 1.12.2 are affected.
What access does an attacker need?
Exploitation requires remote authenticated access. The provided vector indicates low privileges are sufficient and no user interaction is required.
What could an attacker gain?
An attacker could obtain sensitive information by exploiting improper restriction of pathnames to an intended directory.