CVE-2026-105081: ImageMagick before 7.1.2-33 Policy Bypass via Symlink in IsRightsAuthorizedByName

Published Oct 12, 2026
·
Updated

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 does not properly account for symbolic links in the IsRightsAuthorizedByName security policy check, allowing configured policy restrictions to be bypassed. Local attackers who can create a symlink can point it at a policy-restricted path to evade the configured policy.

Affected Software

7 affected componentsFixes available
ImageMagick ImageMagick<6.9.13-58, <7.1.2-33
debian/imagemagick<8:6.9.11.60+dfsg-1.6+deb12u15
8:6.9.11.60+dfsg-1.6+deb12u15
debian/imagemagick*
debian/imagemagick<8:7.1.2.33+dfsg1-1
8:7.1.2.33+dfsg1-1
debian/imagemagick<=8:6.9.11.60+dfsg-1.6+deb12u11, <=8:7.1.1.43+dfsg1-1+deb13u12, <=8:7.1.1.43+dfsg1-1+deb13u13
8:6.9.11.60+dfsg-1.6+deb12u158:7.1.2.34+dfsg1-1
ImageMagick ImageMagick<6.9.13-58
ImageMagick ImageMagick>=7.0.0-0<7.1.2-33

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/imagemagick to a version that resolves this vulnerability.

    Fixed in 8:6.9.11.60+dfsg-1.6+deb12u15
  2. Upgrade

    Upgrade debian/imagemagick to a version that resolves this vulnerability.

    Fixed in 8:7.1.2.33+dfsg1-1
  3. Upgrade

    Upgrade debian/imagemagick to a version that resolves this vulnerability.

    Fixed in 8:6.9.11.60+dfsg-1.6+deb12u15Fixed in 8:7.1.2.34+dfsg1-1
  4. Upgrade

    Upgrade ImageMagick 6.x to a version that resolves this vulnerability.

    Fixed in 6.9.13-58
  5. Upgrade

    Upgrade ImageMagick 7.x to a version that resolves this vulnerability.

    Fixed in 7.1.2-33

Event History

Oct 12, 2026
CVE Published
via MITRE·01:10 PM
Data Sourced
via MITRE·01:10 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·01:17 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:17 PM
Affected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

Who is exposed to this issue?

Systems using ImageMagick before 6.9.13-58 or 7.x before 7.1.2-33 are exposed if they rely on configured ImageMagick security policies to restrict access to particular paths and allow a local attacker to create symbolic links.

2

What does an attacker need to exploit it?

The attacker needs local access with permission to create a symbolic link. They can point that link to a path restricted by ImageMagick policy, causing the policy check to be bypassed.

3

Are default installations necessarily affected?

The issue concerns configured security-policy restrictions on paths. The provided information does not establish that an installation without relevant policy restrictions is affected.

4

What should be done if immediate upgrading is not possible?

Limit untrusted local users' ability to create symbolic links in locations processed by ImageMagick, and avoid processing attacker-controlled paths where policy restrictions are relied upon. Upgrade to ImageMagick 6.9.13-58 or later in the 6.x series, or 7.1.2-33 or later in the 7.x series.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203