CVE-2026-106498: Backstage: Improper URL validation in catalog entity placeholder resolution

Published Oct 6, 2026
·
Updated

Impact

An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user.

Patches

Patched in @backstage/plugin-catalog-backend version 3.9.1

Workarounds

If you're not able to update immediately:

- Limit the scope of integration credentials (e.g., GitHub tokens) to only the repositories that Backstage needs to access.

Other sources

Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.

— MITRE

Affected Software

12 affected componentsFixes available
npm/@backstage/plugin-catalog-backend<3.5.1, <3.6.2, <3.7.2, <3.8.2, <3.9.1
npm/@backstage/plugin-catalog-backend<3.9.1
3.9.1
linuxfoundation Backstage Plugin-catalog-backend Node.js<3.5.1
linuxfoundation Backstage Plugin-catalog-backend Node.js>=3.6.0<3.6.2
linuxfoundation Backstage Plugin-catalog-backend Node.js>=3.7.0<3.7.2
linuxfoundation Backstage Plugin-catalog-backend Node.js>=3.8.0<3.8.2
linuxfoundation Backstage Plugin-catalog-backend Node.js>=3.9.0<3.9.1
linuxfoundation Backstage<1.49.6
linuxfoundation Backstage>=1.50.0<1.50.5
linuxfoundation Backstage>=1.51.0<1.51.3
linuxfoundation Backstage>=1.52.0<1.53.2
linuxfoundation Backstage>=1.54.0<1.54.6

Event History

Oct 6, 2026
CVE Published
via MITRE·09:23 PM
Data Sourced
via MITRE·09:23 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·10:17 PM
RemedyDescriptionSeverityWeaknessAffected Software
Oct 7, 2026
Advisory Published
via GitHub·05:59 PM
Data Sourced
via GitHub·05:59 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

Who can exploit this issue?

An authenticated Backstage user who can craft a catalog entity containing placeholder directives can attempt exploitation. Exposure depends on configurations where those directives can retrieve resources outside the entity's source repository.

2

Which versions contain the fix?

The issue is fixed in @backstage/plugin-catalog-backend versions 3.5.1, 3.6.2, 3.7.2, 3.8.2, and 3.9.1. Versions prior to those releases are affected.

3

What is the potential impact?

Under certain configurations, placeholder resolution may let an authenticated user access data that was not intended to be available to them. The vulnerability concerns references to resources outside the catalog entity's source repository.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203