CVE-2026-106582: Low severity OpenSSH sshd vulnerability
In sshd and ssh in OpenSSH before 10.6, an LZ77 dictionary coder can be used even though this is contraindicated by the arXiv 2609.07709 "Crossing the Streams" findings.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/opensshto a version that resolves this vulnerability.Fixed in 1:10.6p1-1 - Upgrade
Upgrade
debian/openssh-gssapito a version that resolves this vulnerability.Fixed in 1:10.6p1-1 - Upgrade
Upgrade
azurelinux/opensshto a version that resolves this vulnerability.Fixed in 9.8p1-11 - Upgrade
Upgrade
OpenSSHto a version that resolves this vulnerability.Fixed in 10.6
Event History
Frequently Asked Questions
Which deployments are affected?
The issue affects both OpenSSH sshd and the OpenSSH ssh client in versions before 10.6.
What access does an attacker need?
The vector is network-based and requires no privileges or user interaction, but exploitation has high attack complexity.
What is the expected impact?
The stated impact is limited to low confidentiality impact. No integrity or availability impact is listed.
What should be done to remediate the issue?
Upgrade OpenSSH sshd and ssh to version 10.6 or later.