CVE-2026-107348: Integer overflow causes an infinite loop in message buffer growth in PgBouncer

Published Oct 14, 2026
·
Updated

Integer overflow causes an infinite loop in message buffer growth in PgBouncer

Other sources

Integer overflow in the message buffer growth logic (mbufmakeroom) in PgBouncer 1.21.0 through 1.26.0 allows a remote attacker to cause a denial of service when maxpacketsize is configured above 2147483648. A packet header declaring a length above 2^31 makes the buffer size computation overflow, leaving the growth loop unable to terminate. Because PgBouncer serves all clients from a single process, this saturates a CPU core and stalls every pooled connection until the process is restarted. Since 1.23.0 the overflow is reachable before authentication with a five-byte packet header.

— Ubuntu

Affected Software

10 affected componentsFixes available
PgBouncer PgBouncer>=1.21.0<=1.26.0
Microsoft azl3 pgbouncer 1.25.2-1<1.26.1-1
1.26.1-1
ubuntu/pgbouncer*
ubuntu/pgbouncer*
ubuntu/pgbouncer*
ubuntu/pgbouncer*
ubuntu/pgbouncer*
ubuntu/pgbouncer*
ubuntu/pgbouncer*
debian/pgbouncer<=1.18.0-1+deb12u1, <=1.24.1-1+deb13u2
1.26.1-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 1.26.1-1
  2. Upgrade

    Upgrade debian/pgbouncer to a version that resolves this vulnerability.

    Fixed in 1.26.1-1
  3. Configuration

    Configure max_packet_size to 2147483648 or lower to avoid the overflow condition.

    PgBouncer max_packet_size = 2147483648 or lower

Event History

Oct 14, 2026
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·05:34 PM
Data Sourced
via MITRE·05:34 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·06:17 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·06:17 PM
DescriptionSeverityWeakness
Oct 16, 2026
Data Sourced
via Microsoft·08:06 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this denial of service?

PgBouncer versions 1.21.0 through 1.26.0 are affected when max_packet_size is configured above 2147483648. The impact is process-wide: one triggered loop can stall every pooled connection served by that PgBouncer process.

2

What does an attacker need to send to trigger the issue?

The attacker must be able to send a packet with a header declaring a length greater than 2^31. In versions since 1.23.0, the vulnerable path can be reached before authentication using a five-byte packet header.

3

What can be done if an update cannot be applied immediately?

Ensure max_packet_size is not configured above 2147483648, as that configuration is required for the described overflow condition. If the issue is triggered, the affected PgBouncer process must be restarted to restore pooled connections.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203