CVE-2026-107914: High severity Backdrop Backdrop CMS vulnerability

Published Oct 9, 2026
·
Updated

Backdrop CMS 1.34 before 1.34.5 and 1.35 before 1.35.1 doesn't sufficiently protect configuration exports when delivering a compressed archive. This vulnerability is mitigated by the fact that an export must have been previously requested by someone with the "Synchronize, import, and export configuration" permission. NOTE: CVE-2026-107914 refers to the vulnerability in which config.admin.inc does not ensure that a fileunmanageddelete operation occurs. Therefore, many archives could persist: config.tar.gz, config0.tar.gz, config1.tar.gz, etc. There is a separate config.module issue that could allow remote access by an anonymous user, but only for the one filename config.tar.gz.

Affected Software

1 affected component
Backdrop Backdrop CMS>=1.34.0<1.34.5, >=1.35.0<1.35.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Backdrop CMS to a version that resolves this vulnerability.

    Fixed in 1.34.5
  2. Upgrade

    Upgrade Backdrop CMS to a version that resolves this vulnerability.

    Fixed in 1.35.1
  3. Compensating control

    Require the "Synchronize, import, and export configuration" permission before allowing a configuration export to be requested.

Event History

Oct 9, 2026
CVE Published
via MITRE·05:18 AM
Data Sourced
via MITRE·05:18 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·06:17 AM
DescriptionSeverityWeakness

Frequently Asked Questions

1

Who is realistically exposed to this issue?

Backdrop CMS sites running versions 1.34 before 1.34.5 or 1.35 before 1.35.1 are affected only if a configuration export has previously been requested by a user with the "Synchronize, import, and export configuration" permission.

2

What access does an attacker need to exploit it?

The vector is local and requires high attack complexity, but no privileges or user interaction are required according to the supplied severity metrics. Exploitation also depends on the prerequisite configuration export request.

3

What should be prioritized for remediation?

Upgrade affected 1.34 installations to 1.34.5 or later, and affected 1.35 installations to 1.35.1 or later. Review which users hold the configuration synchronization, import, and export permission, since use of that permission to request an export is a stated prerequisite.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203