CVE-2026-109518: APT RCE via hard link reuse

Published Nov 4, 2026
·
Updated

On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic (including a malicious mirror or proxy) between an APT client and an archive server triggered by a package install can trick the client into installing an attacker-controlled unverified package and achieve remote code execution with root privileges.

The vulnerability is caused by the reuse of hard links and requires the client to follow redirects and retry the download of package files. It requires the client to have a non-zero Acquire::Retries configuration setting; the value 3 is the default starting with Debian 12 (bookworm) and Ubuntu 22.04 LTS (Jammy Jellyfish), so older releases are unaffected in a default configuration

Affected Software

12 affected componentsFixes available
debian/apt<2.6.2
2.6.2
debian/apt<3.0.4
3.0.4
debian/apt*
debian/apt<=2.6.1, <=3.0.3, <=3.3.5
2.6.23.0.4
ubuntu/apt*
ubuntu/apt*
ubuntu/apt*
ubuntu/apt*
ubuntu/apt*
ubuntu/apt*
ubuntu/apt*
ubuntu/apt*

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/apt to a version that resolves this vulnerability.

    Fixed in 2.6.2
  2. Upgrade

    Upgrade debian/apt to a version that resolves this vulnerability.

    Fixed in 3.0.4
  3. Upgrade

    Upgrade debian/apt to a version that resolves this vulnerability.

    Fixed in 2.6.2Fixed in 3.0.4
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Patch DSA 6607-1
  5. Configuration

    Set Acquire::Retries to 0 to prevent the non-zero retry condition required for exploitation.

    APT Acquire::Retries = 0

Event History

Oct 23, 2026
Exploit Published
via GitHub·07:20 AM
Nov 4, 2026
CVE Published
via OSV·12:00 PM
Data Sourced
via OSV·12:00 PM
DescriptionSeverityAffected Software
CVE Published
via MITRE·03:49 PM
Data Sourced
via MITRE·03:49 PM
DescriptionWeakness
Data Sourced
via NVD·04:17 PM
DescriptionSeverityWeakness

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

Which systems are affected by default?

Debian 12 (bookworm), Ubuntu 22.04 LTS (Jammy Jellyfish), and derivatives are affected in their default configuration because Acquire::Retries defaults to 3. Older releases are unaffected when left at their default configuration.

2

What conditions must an attacker meet to exploit this?

The attacker must be able to manipulate HTTP traffic between the APT client and the archive server, such as through a malicious mirror or proxy. Exploitation also requires a package installation, redirect following, a retried package download, and a non-zero Acquire::Retries setting.

3

What can be changed if patching is not immediately possible?

Set Acquire::Retries to zero, because exploitation requires a non-zero value. This may reduce APT's ability to recover automatically from failed package downloads.

4

How serious is successful exploitation?

A successful attacker can cause installation of an attacker-controlled unverified package and obtain remote code execution with root privileges. Public exploit code was published on 2026-10-23.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203