CVE-2026-109924: undici vulnerable to Denial of Service via unbounded memory in the EventSource parser

Published Oct 15, 2026
·
Updated

Impact

undici's EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data: fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state. The byte-based maxEventSize and maxResponseSize limits do not bound that retained state, and maxResponseSize is enforced on the compressed body before decompression, so a small compressed response can expand into enough retained memory to terminate the process. The application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response. Availability is the only impact.

Patches

Upgrade to 6.29.1, 7.30.1, or 8.12.2, which bound the retained EventSource parser state (the number of data fields and buffered chunks, the unfinished-line length, and per-field byte totals) independently of the byte limits.

Workarounds

None.

Other sources

undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.

— Ubuntu

Affected Software

11 affected componentsFixes available
npm/undici>=6.5.0<=6.29.0, >=7.0.0<=7.30.0, >=8.0.0<=8.12.1
Nodejs Undici Node.js>=6.5.0<6.29.1
Nodejs Undici Node.js>=7.0.0<7.30.1
Nodejs Undici Node.js>=8.0.0<8.12.2
npm/undici>=8.0.0<8.12.2
8.12.2
npm/undici>=7.0.0<7.30.1
7.30.1
npm/undici>=6.5.0<6.29.1
6.29.1
ubuntu/node-undici*
ubuntu/node-undici*
ubuntu/node-undici*
debian/node-undici<=5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4, <=5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3, <=7.3.0+dfsg1+~cs24.12.11-1, <=8.10.2+dfsg+~cs3.2.2-1
8.12.2+dfsg+~cs3.2.3-2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade npm/undici to a version that resolves this vulnerability.

    Fixed in 8.12.2
  2. Upgrade

    Upgrade npm/undici to a version that resolves this vulnerability.

    Fixed in 7.30.1
  3. Upgrade

    Upgrade npm/undici to a version that resolves this vulnerability.

    Fixed in 6.29.1
  4. Upgrade

    Upgrade debian/node-undici to a version that resolves this vulnerability.

    Fixed in 8.12.2+dfsg+~cs3.2.3-2
  5. Upgrade

    Upgrade undici to a version that resolves this vulnerability.

    Fixed in 6.29.1
  6. Upgrade

    Upgrade undici to a version that resolves this vulnerability.

    Fixed in 7.30.1
  7. Upgrade

    Upgrade undici to a version that resolves this vulnerability.

    Fixed in 8.12.2

Event History

Oct 15, 2026
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·06:16 PM
Data Sourced
via MITRE·06:16 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·07:17 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·07:17 PM
DescriptionSeverityWeaknessAffected Software
Oct 23, 2026
Advisory Published
via GitHub·10:13 PM
Data Sourced
via GitHub·10:13 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

Which applications are exposed to this issue?

Applications using an affected undici version are exposed only if they maintain an EventSource connection to an untrusted or compromised Server-Sent Events peer. The peer needs control of the HTTP response; no attacker privileges or user interaction are required.

2

What can an attacker do?

A malicious SSE peer can cause unbounded retained parser state and exhaust the Node.js process memory, potentially terminating the process. The stated impact is limited to availability; confidentiality and integrity are not affected.

3

Do the existing EventSource size limits prevent exploitation?

No. The byte-based maxEventSize and maxResponseSize limits do not bound the affected per-field and per-chunk parser state, and maxResponseSize is applied to the compressed body before decompression.

4

What should teams do if they use an affected release?

Upgrade undici to 6.29.1, 7.30.1, 8.12.2, or a later version in the applicable release line. No workaround is available if patching cannot be performed.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203