CVE-2026-110720: Consul-k8s vulnerable to a cross-namespace authorization bypass in component ACL binding rules
Consul-k8s versions 0.42.0 and later are vulnerable to a cross-namespace authorization bypass in component ACL binding rules that may allow an attacker to obtain elevated Consul privileges. This vulnerability (CVE-2026-110720) is fixed in consul-k8s 2.1.0 and 1.8.18.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
consul-k8sto a version that resolves this vulnerability.Fixed in 2.1.0 - Upgrade
Upgrade
consul-k8sto a version that resolves this vulnerability.Fixed in 1.8.18
Event History
Frequently Asked Questions
Which deployments are affected?
Consul-k8s versions 0.42.0 and later are affected, except for releases that include the fix: 1.8.18 and 2.1.0. The issue concerns component ACL binding rules and can cross namespace boundaries.
What level of access does an attacker need?
The CVSS vector indicates that exploitation is network-accessible, requires low privileges, and does not require user interaction. Successful exploitation may allow the attacker to obtain elevated Consul privileges.
What should teams upgrade to?
Upgrade Consul-k8s to version 1.8.18 or 2.1.0, which contain the fix.