CVE-2026-111379: FreeRDP before 3.32.0 Heap Buffer Overflow via persistent_cache_read_entry_v3

Published Oct 16, 2026
·
Updated

FreeRDP before 3.32.0 contains a heap buffer overflow vulnerability in persistentcachereadentryv3 that allows local attackers to corrupt memory by supplying a crafted v3 persistent cache file. Attackers can set large width and height values that wrap the size calculation in persistcachegetdata, causing fread to overflow an undersized buffer and potentially execute code.

Affected Software

12 affected componentsFixes available
FreeRDP freerdp<3.32.0
FreeRDP freerdp<3.32.0
ubuntu/freerdp*
ubuntu/freerdp2*
ubuntu/freerdp*
ubuntu/freerdp2*
ubuntu/freerdp2*
ubuntu/freerdp3<3.32.0+dfsg-0ubuntu0.24.04.1
3.32.0+dfsg-0ubuntu0.24.04.1
ubuntu/freerdp2*
ubuntu/freerdp3<3.32.0+dfsg-0ubuntu0.26.04.1
3.32.0+dfsg-0ubuntu0.26.04.1
debian/freerdp2<=2.11.7+dfsg1-6~deb12u1
debian/freerdp3<=3.15.0+dfsg-2.1+deb13u3
3.32.2+dfsg-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/freerdp3 to a version that resolves this vulnerability.

    Fixed in 3.32.0+dfsg-0ubuntu0.24.04.1
  2. Upgrade

    Upgrade ubuntu/freerdp3 to a version that resolves this vulnerability.

    Fixed in 3.32.0+dfsg-0ubuntu0.26.04.1
  3. Upgrade

    Upgrade debian/freerdp3 to a version that resolves this vulnerability.

    Fixed in 3.32.2+dfsg-1

Event History

Oct 16, 2026
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·01:17 AM
Data Sourced
via MITRE·01:17 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·03:18 AM
Affected Software
Data Sourced
via NVD·03:18 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

Who is realistically exposed to this issue?

Systems running FreeRDP versions before 3.32.0 are exposed if an attacker can supply or cause the use of a crafted v3 persistent cache file. Exploitation is local and requires low privileges plus user interaction.

2

What does an attacker need to control?

The attacker needs a crafted v3 persistent cache file with large width and height values. Those values can wrap the size calculation, causing data to be read into an undersized heap buffer.

3

What is the impact if exploitation succeeds?

Successful exploitation can corrupt memory and may allow code execution. The vulnerability affects confidentiality, integrity, and availability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203