CVE-2026-112362: @fastify/express vulnerable to path-scoped middleware bypass via absolute-form request targets

Published Oct 27, 2026
·
Updated

@fastify/express is a Fastify plugin that runs Express middleware inside Fastify. In versions 4.0.5 through 4.0.8, when Fastify runs with the non-default ignoreDuplicateSlashes option enabled, the plugin matches path-scoped Express middleware against a URL whose duplicate-slash normalization has also collapsed the separator after an absolute-form request target's scheme, so Fastify's router resolves the request to the scoped path and runs the handler while the Express layer no longer sees that path. As a result, a request using an absolute-form target can reach a handler on a scoped route such as an admin path while the middleware for authentication, authorization, or rate limiting is skipped. An unauthenticated attacker needs only the non-default ignoreDuplicateSlashes option to be enabled. The issue is fixed in @fastify/express 4.0.9, and users should upgrade to 4.0.9 or later. As a workaround, enforce authentication in a Fastify hook such as preHandler that runs after the router resolves the request, or leave ignoreDuplicateSlashes at its default.

Affected Software

1 affected component
npm/@fastify/express>=4.0.5<=4.0.8

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade @fastify/express to a version that resolves this vulnerability.

    Fixed in 4.0.9
  2. Configuration

    Leave ignoreDuplicateSlashes at its default instead of enabling the non-default option.

    Fastify ignoreDuplicateSlashes = default
  3. Configuration

    Enforce authentication in a Fastify preHandler hook that runs after the router resolves the request.

    Fastify preHandler = authentication enforced

Event History

Oct 27, 2026
CVE Published
via MITRE·11:27 AM
Data Sourced
via MITRE·11:27 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·12:17 PM
DescriptionSeverityWeakness

Frequently Asked Questions

1

Which deployments are affected?

Deployments using @fastify/express versions 4.0.5 through 4.0.8 are affected only when Fastify has the non-default ignoreDuplicateSlashes option enabled. Applications with path-scoped Express middleware protecting routes such as admin endpoints are exposed.

2

Does exploitation require authentication or user interaction?

No. An unauthenticated remote attacker can exploit the issue, and no user interaction is required, by sending an absolute-form request target that causes the Express middleware path check to differ from Fastify's route resolution.

3

What can be done if an upgrade cannot be applied immediately?

Leave ignoreDuplicateSlashes at its default setting, or enforce authentication in a Fastify preHandler hook that runs after routing resolves the request. This avoids relying on the bypassable path-scoped Express middleware check.

4

How can I remediate the issue?

Upgrade @fastify/express to version 4.0.9 or later. Review protected routes that rely on path-scoped Express middleware for authentication, authorization, or rate limiting, particularly where ignoreDuplicateSlashes is enabled.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203