CVE-2026-116675: TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
TinyMCEto a version that resolves this vulnerability.Fixed in 7.9.4 - Upgrade
Upgrade
TinyMCEto a version that resolves this vulnerability.Fixed in 8.9.3
Event History
Frequently Asked Questions
Which deployments are exposed?
Deployments using TinyMCE with the media plugin enabled are exposed in the affected version ranges: 7.9.3 before 7.9.4, and 8.5.1 before 8.9.3.
What does an attacker need to exploit this issue?
The issue involves crafted data-mce-object serialization handled by the media plugin. Processing creates attacker-crafted elements in the active document before sanitization, allowing malicious scripts to execute and be stored.
What can be done if an update cannot be applied immediately?
The described exposure is limited to users with the media plugin enabled. Disabling that plugin removes the stated condition under which the vulnerable processing occurs; otherwise, update to 7.9.4 or 8.9.3.