CVE-2026-118640: n8n before 1.123.85, 2.43.5, and 2.44.1 Chat Hub Authorization Bypass
n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass vulnerability in Chat Hub that allows chat-only users to register restricted tool types. Users with the global:chatUser role can add and run tools through chat to execute sandboxed code, access permitted files, and use instance workflows, Data Tables, and agents.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
n8nto a version that resolves this vulnerability.Fixed in 2.44.1
Event History
Frequently Asked Questions
Which users can exploit this issue?
Users assigned the global:chatUser role can exploit the authorization bypass. The issue is specifically relevant where those chat-only users can access Chat Hub.
What access does an attacker need before exploitation?
An attacker needs an existing account with the global:chatUser role. No user interaction is required after that access is obtained.
What can a successful attacker do?
They can register and run restricted tool types through chat, including executing sandboxed code, accessing permitted files, and using instance workflows, Data Tables, and agents.
Which versions should be remediated?
Update n8n to 1.123.85, 2.43.5, or 2.44.1 or later, as applicable. Versions before those releases are affected.