CVE-2026-118905: nvm_ls lets an untrusted version string inject sed commands, executing arbitrary commands with GNU sed

Published Oct 29, 2026
·
Updated

Node Version Manager (nvm) is a POSIX-compliant shell function for managing multiple node.js versions. In versions 0.31.2 through 0.40.5, nvmls filters installed versions with a sed program that embeds the requested version pattern in a \#...# address, escaping . (and, since 0.40.4, #) but not backslash. A version string containing # (or \#) therefore closes the address early, and the rest of it is parsed as sed commands: with GNU sed, the e command runs a shell command as the user; with BSD sed, the w and r commands write and read files. This is reachable whenever an attacker-influenced version string is passed to nvm use, nvm which, nvm ls, nvm version, nvm run, or nvm exec, or to nvm-exec via NODEVERSION, and at least one version is installed. nvm's own .nvmrc parser strips comments, so a bare nvm use is not affected; however, the bash cdnvm and zsh load-nvmrc auto-switch hooks documented in the README read .nvmrc as-is and pass it to nvm ls and nvm version, so a user with one of those hooks installed runs the attacker's command just by changing into a directory under a malicious .nvmrc; scripts that run nvm use "$(cat .nvmrc)" are affected the same way. Version 0.40.6 passes any version pattern containing # or a newline through the .nvmrc content parser first, so no # reaches the sed program.

Affected Software

1 affected component
nvm Node Version Manager>=0.31.2<=0.40.5

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade nvm to a version that resolves this vulnerability.

    Fixed in 0.40.6

Event History

Oct 29, 2026
CVE Published
via MITRE·05:22 AM
Data Sourced
via MITRE·05:22 AM
RemedyDescriptionSeverityWeakness

Frequently Asked Questions

1

Which nvm installations are affected?

Affected versions are 0.31.2 through 0.40.5. Exploitation also requires that at least one Node version is installed.

2

What must an attacker control to trigger this issue?

The attacker must be able to influence a version string passed to nvm use, nvm which, nvm ls, nvm version, nvm run, or nvm exec. The nvm-exec path is affected when the attacker controls NODE_VERSION.

3

Is a normal bare "nvm use" reading .nvmrc affected?

No. nvm's own .nvmrc parser strips comments, so a bare nvm use is not affected. However, the documented bash cdnvm and zsh load-nvmrc auto-switch hooks read .nvmrc as-is and can trigger the issue when entering a directory containing a malicious .nvmrc.

4

Does the impact differ between GNU sed and BSD sed?

Yes. With GNU sed, the injected sed commands can use the e command to run a shell command as the current user. With BSD sed, injected w and r commands can write and read files.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203