CVE-2026-119146: ProFTPD before 1.3.9e and 1.3.10rc5 Buffer Overflow via mod_rewrite utf8trans RewriteMap

Published Oct 30, 2026
·
Updated

ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the modrewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login commands are rewritten, to corrupt session memory and crash the session.

Affected Software

4 affected componentsFixes available
debian/proftpd-dfsg*
debian/proftpd-dfsg*
debian/proftpd-dfsg*
debian/proftpd-dfsg<=1.3.8+dfsg-4+deb12u5, <=1.3.8+dfsg-4+deb12u4, <=1.3.8.c+dfsg-4+deb13u3, <=1.3.9d~dfsg-1
1.3.9e~dfsg-2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/proftpd-dfsg to a version that resolves this vulnerability.

    Fixed in 1.3.9e~dfsg-2

Event History

Oct 30, 2026
CVE Published
via MITRE·11:30 AM
Data Sourced
via MITRE·11:30 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·12:16 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·12:16 PM
Affected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203