CVE-2026-119207: pypdf has possible large memory usage for exceptions in strict mode

Published Oct 29, 2026
·
Updated

Impact

An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires loading an invalid dictionary.

Patches

This has been fixed in pypdf==6.21.3.

Workarounds

If you cannot upgrade yet, consider applying the changes from PR #4265.

Other sources

pypdf is a free and open-source pure-python PDF library. Prior to 6.21.3, pypdf can consume excessive memory when strict mode loads a crafted invalid PDF dictionary. Nested parsing failures add repeated exception text to newly raised errors, allowing a small malformed dictionary to amplify into very large error messages. This issue is fixed in version 6.21.3.

— NVD

Affected Software

7 affected componentsFixes available
debian/pypdf*
debian/pypdf*
debian/pypdf*
debian/pypdf2*
debian/pypdf<=3.4.1-1+deb12u1, <=5.4.0-1, <=6.21.1-1
debian/pypdf2<=2.12.1-3+deb12u1
pip/pypdf<6.21.3
6.21.3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade pip/pypdf to a version that resolves this vulnerability.

    Fixed in 6.21.3
  2. Upgrade

    Upgrade pypdf to a version that resolves this vulnerability.

    Fixed in 6.21.3
  3. Compensating control

    If unable to upgrade, apply the changes from PR #4265.

Event History

Oct 29, 2026
CVE Published
via MITRE·08:38 PM
Data Sourced
via MITRE·08:38 PM
DescriptionWeakness
Data Sourced
via OSV·08:38 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·09:17 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·09:17 PM
Affected Software
Oct 30, 2026
Advisory Published
via GitHub·11:08 PM
Data Sourced
via GitHub·11:08 PM
DescriptionWeaknessAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this issue?

Deployments using pypdf versions prior to 6.21.3 are affected when strict mode processes a crafted PDF containing an invalid dictionary. The issue can affect software that accepts attacker-controlled PDFs for parsing.

2

What does an attacker need to do to trigger the excessive memory use?

An attacker needs to provide a malformed PDF with an invalid dictionary that causes nested parsing failures in strict mode. No privileges are indicated, but user interaction is required according to the supplied severity vector.

3

What should be done if upgrading is not immediately possible?

Apply the changes from PR #4265 as a workaround. Otherwise, avoid processing untrusted malformed PDFs in strict mode until the fix can be deployed.

4

How can I determine whether my installation is affected?

Check the installed pypdf version and whether strict mode is used to load PDFs. Versions before 6.21.3 that parse crafted invalid PDF dictionaries in strict mode are affected.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203