CVE-2026-119729: Gst-plugins-base: gst-plugins-bad: gst-plugins-base/gst-plugins-bad: integer overflow in av1 leb128 parser allows denial of service

Published Oct 30, 2026
·
Updated

A flaw was found in GStreamer. An integer overflow vulnerability in the AV1 LEB128 variable-length integer parser allows a remote attacker to cause a crash in applications that process AV1 media content. By crafting a malformed AV1 bitstream containing an invalid LEB128-encoded value, an attacker can cause integer overflow in the parser, resulting in incorrect length values being used during stream processing, which can lead to a denial of service.

Affected Software

19 affected componentsFixes available
debian/gst-plugins-bad1.0*
debian/gst-plugins-bad1.0*
debian/gst-plugins-bad1.0<1.28.2-1
1.28.2-1
debian/gst-plugins-base1.0*
debian/gst-plugins-base1.0*
debian/gst-plugins-base1.0<1.28.2-1
1.28.2-1
debian/gst-plugins-bad1.0<=1.22.0-4+deb12u7, <=1.22.0-4+deb12u8, <=1.26.2-3+deb13u3
1.28.8-1
debian/gst-plugins-base1.0<=1.22.0-3+deb12u6, <=1.22.0-3+deb12u7, <=1.26.2-1+deb13u1, <=1.26.2-1+deb13u2
1.28.8-1
ubuntu/gst-plugins-bad1.0*
ubuntu/gst-plugins-base1.0*
ubuntu/gst-plugins-bad1.0*
ubuntu/gst-plugins-base1.0*
ubuntu/gst-plugins-bad1.0*
ubuntu/gst-plugins-base1.0*
ubuntu/gst-plugins-bad1.0*
ubuntu/gst-plugins-base1.0*
ubuntu/gst-plugins-bad1.0*
ubuntu/gst-plugins-base1.0*
ubuntu/gst-plugins-bad1.0*

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/gst-plugins-bad1.0 to a version that resolves this vulnerability.

    Fixed in 1.28.2-1
  2. Upgrade

    Upgrade debian/gst-plugins-base1.0 to a version that resolves this vulnerability.

    Fixed in 1.28.2-1
  3. Upgrade

    Upgrade debian/gst-plugins-bad1.0 to a version that resolves this vulnerability.

    Fixed in 1.28.8-1
  4. Upgrade

    Upgrade debian/gst-plugins-base1.0 to a version that resolves this vulnerability.

    Fixed in 1.28.8-1

Event History

Oct 30, 2026
CVE Published
via MITRE·06:34 PM
Data Sourced
via MITRE·06:34 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·07:18 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·07:18 PM
DescriptionSeverityAffected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203