CVE-2026-119922: Babelfish for PostgreSQL Privilege Escalation
Improper access control in the Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 may allow remote authenticated users to elevate their privileges. To remediate this issue, we recommend you upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later.
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Babelfish for PostgreSQL extensionto a version that resolves this vulnerability.Fixed in 4.10 - Upgrade
Upgrade
Babelfish for PostgreSQL extensionto a version that resolves this vulnerability.Fixed in 5.6 - Upgrade
Upgrade
Babelfish for PostgreSQL extensionto a version that resolves this vulnerability.Fixed in 6.1