CVE-2026-120065: SQL Injection

Published Nov 2, 2026
·
Updated

For an updatable cursor over a table without OIDs that has an auto-increment int4 column, psqlODBC uses that column to identify rows. It places the column's name, as reported by the server, between double quotes in its keyset queries and in the WHERE clause of its positioned SELECT, UPDATE, and DELETE statements, without doubling any double quote in the name. A column name that contains a double quote therefore changes the SQL that the driver runs with the application's privileges, including which rows a positioned UPDATE or DELETE affects. Any database user who can create a table that the application reads with an updatable cursor can choose such a name, and so can a server not trusted under current SSL settings. Versions before psqlODBC 18.00.0006 are affected.

Affected Software

11 affected componentsFixes available
debian/psqlodbc*
debian/psqlodbc*
debian/psqlodbc*
debian/psqlodbc<=1:13.02.0000-2, <=1:17.00.0004-2, <=1:18.00.0005-1
1:18.00.0006-1
ubuntu/psqlodbc*
ubuntu/psqlodbc*
ubuntu/psqlodbc*
ubuntu/psqlodbc*
ubuntu/psqlodbc*
ubuntu/psqlodbc*
ubuntu/psqlodbc*

Event History

Nov 2, 2026
CVE Published
via NVD·07:18 PM
Data Sourced
via NVD·07:18 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·07:18 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

Who can exploit this vulnerability?

A database user who can create a table that the application reads through an updatable cursor can supply a column name containing a double quote. A server that is not trusted under the current SSL settings can also provide a malicious column name.

2

What application behavior is required for exploitation?

The application must use an updatable cursor on a table without OIDs that has an auto-increment int4 column. The vulnerable driver then uses that column name in keyset and positioned SELECT, UPDATE, or DELETE queries.

3

What is the potential impact?

Injected SQL runs with the application's database privileges. An attacker can alter the SQL used by positioned UPDATE or DELETE statements, including changing which rows those statements affect.

4

Which versions need to be remediated?

psqlODBC versions before 18.00.0006 are affected. Upgrade to 18.00.0006 or a later version.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203