CVE-2026-120634: CGI::Carp versions before 5.00 for Perl leak warnings across requests in persistent environments via the warningsToBrowser buffer

Published Nov 3, 2026
·
Updated

CGI::Carp versions before 5.00 for Perl leak warnings across requests in persistent environments via the warningsToBrowser buffer.

Warnings are held in a package-level buffer until warningsToBrowser writes them into the page as HTML comments, and the buffer is never cleared between requests. Under modperl, FastCGI or PSGI, warnings from one request are written into a later one.

Warnings that contain one user's request data can appear in the HTML sent to another user.

Affected Software

4 affected components
debian/libcgi-pm-perl*
debian/libcgi-pm-perl*
debian/libcgi-pm-perl*
debian/libcgi-pm-perl<=4.55-1, <=4.68-1, <=4.72-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade CGI::Carp to a version that resolves this vulnerability.

    Fixed in 5.00

Event History

Nov 3, 2026
CVE Published
via MITRE·11:40 PM
Data Sourced
via MITRE·11:40 PM
RemedyDescriptionWeakness
Nov 4, 2026
Data Sourced
via NVD·12:17 AM
DescriptionWeakness
Data Sourced
via OSV·12:17 AM
DescriptionAffected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203