CVE-2026-120635: CGI versions before 5.00 for Perl allow form fields to be smuggled past proxies and WAFs via multipart parsing that differs from the RFCs

Published Nov 3, 2026
·
Updated

CGI versions before 5.00 for Perl allow form fields to be smuggled past proxies and WAFs via multipart parsing that differs from the RFCs.

The multipart/form-data parser matches the boundary anywhere rather than at the start of a line, uses the boundary without its leading -- for some client-supplied User-Agent values, finds the Content-Disposition name and filename inside the quoted values of other parameters, and corrupts parts when the boundary nears the 4096-byte read size.

Affected Software

4 affected components
debian/libcgi-pm-perl*
debian/libcgi-pm-perl*
debian/libcgi-pm-perl*
debian/libcgi-pm-perl<=4.55-1, <=4.68-1, <=4.72-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade CGI for Perl to a version that resolves this vulnerability.

    Fixed in 5.00

Event History

Nov 3, 2026
CVE Published
via MITRE·11:40 PM
Data Sourced
via MITRE·11:40 PM
RemedyDescriptionWeakness
Data Sourced
via OSV·11:40 PM
DescriptionWeakness
Nov 4, 2026
Data Sourced
via NVD·12:17 AM
DescriptionWeakness
Data Sourced
via OSV·12:17 AM
Affected Software

Frequently Asked Questions

1

Which deployments are exposed to this issue?

Deployments using CGI for Perl versions earlier than 5.00 and accepting multipart/form-data requests are exposed. The affected package identified here is debian/libcgi-pm-perl.

2

What does an attacker need to exploit the issue?

An attacker needs to send a crafted multipart/form-data request. The malformed multipart structure can be parsed differently by CGI for Perl than by an intermediary proxy or web application firewall.

3

Can a proxy or WAF prevent exploitation?

Not reliably if it interprets multipart boundaries or Content-Disposition parameters differently from the vulnerable parser. The issue specifically enables fields to be smuggled past such controls through parser discrepancies.

4

What should be done if an immediate upgrade is not possible?

No specific workaround is provided in the available data. Prioritize restricting or carefully validating multipart/form-data handling where possible, because the vulnerable parser behavior affects multipart boundary and Content-Disposition parsing.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203