CVE-2026-122192: High severity vulnerability
Improper handling of a failed memory remap in Firecracker versions 0.23.0 through 1.16.1 might allow a guest user with root privileges to read or modify Firecracker VMM process memory via balloon or virtio-mem discard requests on microVMs restored from a snapshot with the File memory backend, if the host fails to create the replacement mapping.
To remediate this issue, users should upgrade to Firecracker 1.16.2 or 1.17.0 and later.
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firecrackerto a version that resolves this vulnerability.Fixed in 1.16.2 - Upgrade
Upgrade
Firecrackerto a version that resolves this vulnerability.Fixed in 1.17.0