CVE-2026-1402: Allocation of Resources Without Limits or Throttling in GitLab
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.1 before 18.10.7, 18.11 before 18.11.4, and 19.0 before 19.0.1 that under certain conditions could have allowed an authenticated user to cause denial of service due to insufficient validation.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 18.10.7 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 18.11.4 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 19.0.1
Event History
Frequently Asked Questions
What is the severity of CVE-2026-1402?
CVE-2026-1402 has a medium severity score of 6.5.
How do I fix CVE-2026-1402?
To fix CVE-2026-1402, upgrade to GitLab versions 18.10.7, 18.11.4, 19.0.1 or above.
What software is affected by CVE-2026-1402?
CVE-2026-1402 affects GitLab CE and GitLab EE versions prior to 18.10.7, 18.11.4, and 19.0.1.
What kind of issue is described in CVE-2026-1402?
CVE-2026-1402 refers to an issue involving allocation of resources without limits that could lead to denial of service.
When was CVE-2026-1402 published?
CVE-2026-1402 was published on May 27, 2026.