CVE-2026-16524: Pcp: pcp linux_sockets pmda: arbitrary command execution via command injection

Published Jul 22, 2026
·
Updated

A command injection flaw in PCP's linuxsockets PMDA allows malicious shell metacharacters via the network.persocket.filter metric. This failed validation lets attackers execute arbitrary commands as the PMDA user when metrics refresh.

Other sources

A command injection vulnerability exists in the linuxsockets PMDA through the writable metric network.persocket.filter. The validation helper socketscheckfilter() returns 1 for safe input and 0 for unsafe input, but the store handler uses an inverted condition: safe expressions are rejected while malicious ones containing shell metacharacters are silently accepted. The attacker-controlled filter value is later incorporated into a shell command executed via popen() whenever socket metrics are refreshed, enabling arbitrary command execution as the PMDA process user. Prerequisites: • linuxsockets PMDA loaded; • ss binary present (/usr/sbin/ss or /usr/bin/ss); • no [access] section restricting pmstore in pmcd.conf (default behavior).

— Red Hat

Affected Software

6 affected componentsFixes available
PCP/pcp-linux-sockets-pmda
debian/pcp<=6.0.3-1.1, <=6.3.8-1
7.2.2-1
debian/pcp*
debian/pcp*
debian/pcp<7.2.0-1
7.2.0-1
IBM API Connect V12 OnPrem<=v12.1.0.0 - v12.1.1.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/pcp to a version that resolves this vulnerability.

    Fixed in 7.2.0-1
  2. Upgrade

    Upgrade debian/pcp to a version that resolves this vulnerability.

    Fixed in 7.2.2-1

Event History

Jul 22, 2026
Data Sourced
via Red Hat·06:47 AM
DescriptionSeverityAffected Software
Jul 30, 2026
CVE Published
via MITRE·05:15 AM
Data Sourced
via MITRE·05:15 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·06:25 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·06:25 AM
DescriptionSeverityAffected Software
Oct 8, 2026
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2026-16524?

CVE-2026-16524 has a high severity rating of 7.8.

2

What type of vulnerability is represented by CVE-2026-16524?

CVE-2026-16524 is a command injection vulnerability in PCP's linux_sockets PMDA.

3

How can attackers exploit CVE-2026-16524?

Attackers can exploit CVE-2026-16524 by sending malicious shell metacharacters via the network.persocket.filter metric.

4

What impact does CVE-2026-16524 have on affected systems?

CVE-2026-16524 allows attackers to execute arbitrary commands as the PMDA user on affected systems.

5

How do I fix CVE-2026-16524?

To fix CVE-2026-16524, update your PCP linux_sockets PMDA to the latest version that addresses this vulnerability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203