CVE-2026-16526: Pcp: pcp: privilege escalation to root via linux_sockets pmda vulnerability

Published Jul 22, 2026
·
Updated

A flaw in the PCP linuxsockets module exposes an unsecured internal connection. An attacker with initial code execution can exploit this to escalate privileges and execute arbitrary commands as root.

Other sources

Summary: When the linuxsockets PMDA is loaded as a DSO inside PMCD, code execution achieved via Vulnerability 3 (network.persocket.filter injection) can be escalated from user pcp to root. The pmdarootfd Unix socket connection to pmdaroot is created without OCLOEXEC, causing all child processes spawned by popen() to inherit it. pmdaroot runs as root and processes PDUROOTSTARTPMDAREQ without per-request authentication, executing attacker-controlled arguments via execvp() as root. Prerequisites: • Vulnerability 3 (linuxsockets command injection) required for initial code execution - exploitable either locally via pmcd (TCP 44321, localhost only by default) or remotely via the pmproxy REST API (TCP 44322, all interfaces by default, no authentication required). linuxsockets • PMDA loaded as DSO in PMCD (requires explicit configuration in pmcd.conf; default is daemon mode).

— Red Hat

Affected Software

6 affected componentsFixes available
pcp/linux_sockets (PMDA)
debian/pcp<=6.0.3-1.1, <=6.3.8-1
7.2.2-1
debian/pcp*
debian/pcp*
debian/pcp<7.2.0-1
7.2.0-1
IBM API Connect V12 OnPrem<=v12.1.0.0 - v12.1.1.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/pcp to a version that resolves this vulnerability.

    Fixed in 7.2.0-1
  2. Upgrade

    Upgrade debian/pcp to a version that resolves this vulnerability.

    Fixed in 7.2.2-1

Event History

Jul 22, 2026
Data Sourced
via Red Hat·07:26 AM
DescriptionSeverityAffected Software
Jul 30, 2026
CVE Published
via MITRE·05:20 AM
Data Sourced
via MITRE·05:20 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·06:25 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·06:25 AM
DescriptionSeverityAffected Software
Oct 8, 2026
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2026-16526?

The severity of CVE-2026-16526 is rated high with a score of 8.8.

2

How do I fix CVE-2026-16526?

To fix CVE-2026-16526, update the PCP software to the latest patched version that addresses this vulnerability.

3

What types of attacks can exploit CVE-2026-16526?

CVE-2026-16526 can be exploited by an attacker with initial code execution to escalate privileges and execute arbitrary commands as root.

4

What is the impact of CVE-2026-16526 on my system?

The impact of CVE-2026-16526 is significant as it allows for privilege escalation to root, potentially compromising the entire system.

5

Which software components are affected by CVE-2026-16526?

CVE-2026-16526 affects the PCP and linux_sockets module, making those components vulnerable to exploitation.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203