CVE-2026-18537: IBM Maximo Application Suite - Location Service for Esri Component Code Execution

Published Sep 29, 2026
·
Updated

IBM Maximo Application Suite - Location Service for Esri Component 9.2, 9.1, and 9.0 is vulnerable to improper input validation due to an unsanitised container image reference in a Kubernetes operator template.

Other sources

IBM Maximo Application Suite - Location Service for Esri Component is vulnerable to improper input validation due to an unsanitised container image reference in a Kubernetes operator template.

— IBM

Affected Software

4 affected componentsFixes available
IBM Maximo Application Suite - Location Service for Esri Component=9.2, =9.1, =9.0
IBM Maximo Application Suite - Location Service for Esri Component<=9.2
IBM Maximo Application Suite - Location Service for Esri Component<=9.1
IBM Maximo Application Suite - Location Service for Esri Component<=9.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade IBM Maximo Application Suite - Location Service for Esri Component to a version that resolves this vulnerability.

    Fixed in 9.2.3
  2. Upgrade

    Upgrade IBM Maximo Application Suite - Location Service for Esri Component to a version that resolves this vulnerability.

    Fixed in 9.1.13
  3. Upgrade

    Upgrade IBM Maximo Application Suite - Location Service for Esri Component to a version that resolves this vulnerability.

    Fixed in 9.0.14

Event History

Sep 29, 2026
CVE Published
via IBM·12:00 AM
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software
Oct 12, 2026
CVE Published
via MITRE·09:01 PM
Data Sourced
via MITRE·09:01 PM
RemedyDescriptionSeverityWeakness
Data Sourced
via NVD·09:17 PM
DescriptionSeverityWeakness

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

Who can exploit this issue?

An attacker needs high privileges, as indicated by the PR:H vector. The attack can be performed over the network and does not require user interaction.

2

Which deployments are affected?

The affected component versions listed are 9.0, 9.1, and 9.2. The available information does not state whether a default deployment configuration is affected.

3

What is the impact if exploitation succeeds?

The vulnerability can result in code execution through an unsanitised container image reference in a Kubernetes operator template. The CVSS vector indicates high confidentiality and integrity impact, with no availability impact listed.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203