CVE-2026-23078: ALSA: scarlett2: Fix buffer overflow in config retrieval

Published Feb 4, 2026
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

ALSA: scarlett2: Fix buffer overflow in config retrieval

The scarlett2usbgetconfig() function has a logic error in the endianness conversion code that can cause buffer overflows when count > 1.

The code checks if (size == 2) where size is the total buffer size in bytes, then loops count times treating each element as u16 (2 bytes). This causes the loop to access count 2 bytes when the buffer only has size bytes allocated.

Fix by checking the element size (configitem->size) instead of the total buffer size. This ensures the endianness conversion matches the actual element type.

Affected Software

12 affected componentsFixes available
Linux Linux kernel>=5.14<5.15.199
Linux Linux kernel>=5.16<6.1.162
Linux Linux kernel>=6.2<6.6.122
Linux Linux kernel>=6.7<6.12.68
Linux Linux kernel>=6.13<6.18.8
Linux Linux kernel=6.19-rc1
Linux Linux kernel=6.19-rc2
Linux Linux kernel=6.19-rc3
Linux Linux kernel=6.19-rc4
Linux Linux kernel=6.19-rc5
Linux Linux kernel=6.19-rc6
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Feb 4, 2026
CVE Published
via MITRE·04:08 PM
Data Sourced
via MITRE·04:08 PM
Description
Data Sourced
via NVD·05:16 PM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2026-23078?

The CVE-2026-23078 vulnerability is considered to be of medium severity due to the buffer overflow risk.

2

How do I fix CVE-2026-23078?

To resolve CVE-2026-23078, you should update your Linux kernel to the latest version that does not have this vulnerability.

3

What problems does CVE-2026-23078 cause?

CVE-2026-23078 can lead to potential buffer overflow exploits impacting system stability and security.

4

Which software versions are affected by CVE-2026-23078?

CVE-2026-23078 affects various versions of the Linux kernel, specifically those between 5.14 and 6.19-rc6.

5

Does CVE-2026-23078 require immediate action?

Yes, given the nature of the vulnerability, it is advisable to take action as soon as possible to mitigate potential risks.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203