CVE-2026-23387: pinctrl: cirrus: cs42l43: Fix double-put in cs42l43_pin_probe()

Published Mar 25, 2026
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

pinctrl: cirrus: cs42l43: Fix double-put in cs42l43pinprobe()

devmaddactionorreset() already invokes the action on failure, so the explicit put causes a double-put.

Affected Software

15 affected componentsFixes available
Linux Linux kernel (pinctrl: cirrus: cs42l43 driver)
Linux Linux kernel>=6.6.118<6.6.130
Linux Linux kernel>=6.12.60<6.12.77
Linux Linux kernel>=6.17.10<6.18
Linux Linux kernel>=6.18.1<6.18.17
Linux Linux kernel>=6.19<6.19.7
Linux Linux kernel=6.18
Linux Linux kernel=7.0-rc1
Linux Linux kernel=7.0-rc2
Linux Linux kernel=7.0-rc3
Linux Linux kernel=7.0-rc4
Linux Linux kernel=7.0-rc5
Linux Linux kernel=7.0-rc6
Linux Linux kernel=7.0-rc7
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Mar 25, 2026
CVE Published
via MITRE·10:28 AM
Data Sourced
via MITRE·10:28 AM
Description
Data Sourced
via NVD·11:16 AM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2026-23387?

The severity of CVE-2026-23387 is classified as low due to the specific nature of the double-put issue.

2

How do I fix CVE-2026-23387?

To fix CVE-2026-23387, ensure that you update your Linux kernel to the latest version where the vulnerability has been patched.

3

What software is affected by CVE-2026-23387?

CVE-2026-23387 affects the Linux kernel specifically in the context of the pinctrl: cirrus: cs42l43 driver.

4

What is the impact of CVE-2026-23387?

The impact of CVE-2026-23387 is primarily stability-related due to the potential for double reference counting within the driver.

5

Is CVE-2026-23387 exploitable?

CVE-2026-23387 is not considered directly exploitable as it does not allow for arbitrary code execution but may lead to stability issues in the driver.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203