CVE-2026-26269: Vim has a Netbeans specialKeys Stack Buffer Overflow

Published Feb 13, 2026
·
Updated

Vim is an open source, command line text editor. Prior to 9.1.2148, a stack buffer overflow vulnerability exists in Vim's NetBeans integration when processing the specialKeys command, affecting Vim builds that enable and use the NetBeans feature. The Stack buffer overflow exists in specialkeys() (in src/netbeans.c). The while (tok) loop writes two bytes per iteration into a 64-byte stack buffer (keybuf) with no bounds check. A malicious NetBeans server can overflow keybuf with a single specialKeys command. The issue has been fixed as of Vim patch v9.1.2148.

Affected Software

6 affected componentsFixes available
vim Vim<9.1.2148
vim Vim<9.1.2148
debian/vim<=2:9.0.1378-2+deb12u2, <=2:9.1.1230-2
2:9.1.1230-2+deb13u12:9.2.0858-1
debian/vim*
debian/vim<2:9.1.1230-2+deb13u1
2:9.1.1230-2+deb13u1
debian/vim<2:9.2.0119-1
2:9.2.0119-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/vim to a version that resolves this vulnerability.

    Fixed in 2:9.1.1230-2+deb13u1Fixed in 2:9.2.0858-1
  2. Upgrade

    Upgrade debian/vim to a version that resolves this vulnerability.

    Fixed in 2:9.1.1230-2+deb13u1
  3. Upgrade

    Upgrade debian/vim to a version that resolves this vulnerability.

    Fixed in 2:9.2.0119-1
  4. Upgrade

    Upgrade Vim to a version that resolves this vulnerability.

    Fixed in 9.1.2148

Event History

Feb 13, 2026
CVE Published
via MITRE·07:18 PM
Data Sourced
via MITRE·07:18 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·08:17 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:17 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2026-26269?

CVE-2026-26269 is classified as a high severity vulnerability due to the potential for a stack buffer overflow.

2

How do I fix CVE-2026-26269?

To fix CVE-2026-26269, upgrade Vim to version 9.1.2148 or later.

3

Which versions of Vim are affected by CVE-2026-26269?

Vim versions prior to 9.1.2148 are affected by CVE-2026-26269.

4

What functionality in Vim does CVE-2026-26269 impact?

CVE-2026-26269 impacts the NetBeans integration feature in Vim when processing the specialKeys command.

5

Is CVE-2026-26269 remotely exploitable?

CVE-2026-26269 can be exploited locally if the specialKeys command is utilized, posing a risk to users.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203