CVE-2026-28422: Vim has stack-buffer-overflow in build_stl_str_hl()

Published Feb 27, 2026
·
Updated

Vim has stack-buffer-overflow in buildstlstrhl()

Other sources

Vim is an open source, command line text editor. Prior to version 9.2.0078, a stack-buffer-overflow occurs in buildstlstrhl() when rendering a statusline with a multi-byte fill character on a very wide terminal. Version 9.2.0078 patches the issue.

— NVD

Affected Software

10 affected componentsFixes available
vim Vim<9.2.0078
Microsoft azl3 vim 9.1.1616-1
vim Vim<9.2.0078
Microsoft cbl2 vim 9.1.1616-1
debian/vim<=2:9.0.1378-2+deb12u2, <=2:9.1.1230-2
2:9.1.1230-2+deb13u12:9.2.0858-1
debian/vim*
debian/vim<2:9.1.1230-2+deb13u1
2:9.1.1230-2+deb13u1
debian/vim<2:9.2.0119-1
2:9.2.0119-1
alpine/vim<9.2.0078-r0
9.2.0078-r0
alpine/vim<9.2.0078-r0
9.2.0078-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/vim to a version that resolves this vulnerability.

    Fixed in 2:9.1.1230-2+deb13u1Fixed in 2:9.2.0858-1
  2. Upgrade

    Upgrade debian/vim to a version that resolves this vulnerability.

    Fixed in 2:9.1.1230-2+deb13u1
  3. Upgrade

    Upgrade debian/vim to a version that resolves this vulnerability.

    Fixed in 2:9.2.0119-1
  4. Upgrade

    Upgrade alpine/vim to a version that resolves this vulnerability.

    Fixed in 9.2.0078-r0
  5. Upgrade

    Upgrade Vim to a version that resolves this vulnerability.

    Fixed in 9.2.0078

Event History

Feb 27, 2026
CVE Published
via MITRE·10:08 PM
Data Sourced
via MITRE·10:08 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·10:16 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:16 PM
DescriptionSeverityAffected Software
Mar 1, 2026
Data Sourced
via Microsoft·09:01 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2026-28422?

CVE-2026-28422 has been classified as a high severity vulnerability due to the potential for a stack-buffer overflow.

2

How do I fix CVE-2026-28422?

To mitigate CVE-2026-28422, update Vim to version 9.2.0078 or later.

3

What version of Vim is affected by CVE-2026-28422?

Vim versions prior to 9.2.0078 are affected by CVE-2026-28422.

4

What causes the vulnerability CVE-2026-28422?

CVE-2026-28422 is caused by a stack-buffer overflow in the build_stl_str_hl() function when rendering a statusline with a multi-byte fill character.

5

Is CVE-2026-28422 a local or remote vulnerability?

CVE-2026-28422 is considered a local vulnerability, as it requires access to the system running the affected version of Vim.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203