CVE-2026-32281: Inefficient policy validation in crypto/x509

Published Apr 8, 2026
·
Updated

Inefficient policy validation in crypto/x509

Other sources

Validating certificate chains which use policies is unexpectedly inefficient when certificates in the chain contain a very large number of policy mappings, possibly causing denial of service. This only affects validation of otherwise trusted certificate chains, issued by a root CA in the VerifyOptions.Roots CertPool, or in the system certificate pool.

— MITRE

Affected Software

7 affected componentsFixes available
go crypto/x509
Golang Go<1.25.9
Golang Go>=1.26.0<1.26.2
IBM Concert Software<=1.0.0-3.0.0
alpine/go>=1.26.0<1.25.9-r0
1.25.9-r0
alpine/go>=1.26.0<1.26.2-r0
1.26.2-r0
alpine/rclone<1.73.5-r0
1.73.5-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/go to a version that resolves this vulnerability.

    Fixed in 1.25.9-r0
  2. Upgrade

    Upgrade alpine/go to a version that resolves this vulnerability.

    Fixed in 1.26.2-r0
  3. Upgrade

    Upgrade alpine/rclone to a version that resolves this vulnerability.

    Fixed in 1.73.5-r0

Event History

Apr 8, 2026
CVE Published
via MITRE·01:06 AM
Data Sourced
via MITRE·01:06 AM
DescriptionWeakness
Data Sourced
via OSV·01:06 AM
DescriptionSeverity
Data Sourced
via Red Hat·02:01 AM
DescriptionSeverityAffected Software
Data Sourced
via NVD·02:16 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:16 AM
Affected Software
Apr 11, 2026
Data Sourced
via Microsoft·08:06 AM
DescriptionSeverityWeakness
Sep 22, 2026
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2026-32281?

CVE-2026-32281 is considered a denial of service vulnerability due to inefficient policy validation in the Go crypto/x509 library.

2

How do I fix CVE-2026-32281?

To fix CVE-2026-32281, upgrade to Go version 1.26.2 or later, as previous versions contain the vulnerability.

3

What software is affected by CVE-2026-32281?

CVE-2026-32281 affects the Go crypto/x509 library, specifically versions prior to 1.26.2 and those up to 1.25.9.

4

How can CVE-2026-32281 impact my application?

CVE-2026-32281 can cause denials of service due to inefficient validation of certificate chains with many policy mappings.

5

Is there a workaround for CVE-2026-32281 before upgrading?

There are no officially recommended workarounds for CVE-2026-32281, so upgrading to a patched version is advised.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203