CVE-2026-34897: WordPress Media LIbrary Assistant plugin <= 3.34 - Cross Site Scripting (XSS) vulnerability
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in David Lingren Media LIbrary Assistant allows Stored XSS.This issue affects Media LIbrary Assistant: from n/a through 3.34.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
WordPress Media Library Assistant pluginto a version that resolves this vulnerability.Fixed in 3.35
Event History
Frequently Asked Questions
What is the severity of CVE-2026-34897?
The severity of CVE-2026-34897 is medium with a score of 6.5.
How do I fix CVE-2026-34897?
To fix CVE-2026-34897, update the WordPress Media Library Assistant Plugin to version 3.35 or later.
What type of vulnerability is CVE-2026-34897?
CVE-2026-34897 is a Cross Site Scripting (XSS) vulnerability.
Which versions of the Media Library Assistant are affected by CVE-2026-34897?
CVE-2026-34897 affects Media Library Assistant versions prior to 3.35.
What is the impact of CVE-2026-34897?
CVE-2026-34897 allows for Stored Cross Site Scripting, which can lead to unauthorized actions being executed in the context of another user.