CVE-2026-44927: uriparser 1.0.2 fixes CVE-2026-44927 and CVE-2026-44928
Fixed CVE-2026-44927 (In uriparser before 1.0.2, there is pointer difference truncation to int in various places). (CVE-2026-44927)
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 8.5.7 - Upgrade
Upgrade
alpine/php85to a version that resolves this vulnerability.Fixed in 8.5.12-r0 - Upgrade
Upgrade
alpine/php85to a version that resolves this vulnerability.Fixed in 8.5.7-r0 - Upgrade
Upgrade
alpine/uriparserto a version that resolves this vulnerability.Fixed in 1.0.2-r0 - Upgrade
Upgrade
uriparserto a version that resolves this vulnerability.Fixed in 1.0.2
Event History
Frequently Asked Questions
What is the severity of CVE-2026-44927?
CVE-2026-44927 has been categorized as a medium severity vulnerability.
How do I fix CVE-2026-44927?
To fix CVE-2026-44927, upgrade uriparser to version 1.0.2 or higher.
What are the implications of CVE-2026-44927?
The implications of CVE-2026-44927 include potential data corruption or crashes due to pointer difference truncation.
Which versions of uriparser are affected by CVE-2026-44927?
Versions of uriparser prior to 1.0.2 are affected by CVE-2026-44927.
Is CVE-2026-44927 a remote or local vulnerability?
CVE-2026-44927 is considered a local vulnerability, as it affects operations within the software itself.