CVE-2026-46088: ALSA: control: Validate buf_len before strnlen() in snd_ctl_elem_init_enum_names()

Published May 27, 2026
·
Updated

ALSA: control: Validate buflen before strnlen() in sndctleleminitenumnames()

Affected Software

9 affected componentsFixes available
Linux Linux kernel (ALSA)
Linux Linux kernel>=3.2<5.10.258
Linux Linux kernel>=5.11<5.15.209
Linux Linux kernel>=5.16<6.1.175
Linux Linux kernel>=6.2<6.6.140
Linux Linux kernel>=6.7<6.12.86
Linux Linux kernel>=6.13<6.18.27
Linux Linux kernel>=6.19<7.0.4
Microsoft azl3 kernel 6.6.139.1-1<6.6.141.1-1
6.6.141.1-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 6.6.141.1-1
  2. Configuration

    In snd_ctl_elem_init_enum_names(), add a buf_len == 0 guard at loop entry to prevent calling fortified strnlen(p, 0) when the buffer is exhausted (buf_len reaches zero).

    Linux kernel (snd_ctl_elem_init_enum_names) buf_len guard at loop entry = Add check: buf_len == 0 -> return/stop before calling fortified strnlen()
  3. Compensating control

    Ensure systems with CONFIG_FORTIFY_SOURCE enabled are updated with the kernel fix, to avoid BRK exception panic triggered by fortified strnlen() in the exhausted-buffer loop.

Event History

May 27, 2026
CVE Published
via MITRE·12:58 PM
Data Sourced
via MITRE·12:58 PM
Description
Data Sourced
via NVD·02:17 PM
RemedyDescriptionSeverityAffected Software
May 28, 2026
Data Sourced
via Microsoft·08:05 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2026-46088?

CVE-2026-46088 has a risk score of 23, indicating a critical severity level.

2

How do I fix CVE-2026-46088?

To fix CVE-2026-46088, upgrade to the latest version of the Linux kernel that includes the patch addressing this vulnerability.

3

What impact does CVE-2026-46088 have on the Linux kernel?

CVE-2026-46088 could allow for potential memory corruption due to improper validation of buffer lengths, leading to system instability.

4

Is CVE-2026-46088 exploitable remotely?

There is no indication that CVE-2026-46088 is exploitable remotely; it primarily affects local access.

5

Which version of Linux is affected by CVE-2026-46088?

CVE-2026-46088 affects the ALSA control subsystem in the Linux kernel prior to the patched version.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203