CVE-2026-46204: drm/amdgpu/vcn4: Prevent OOB reads when parsing IB

Published May 28, 2026
·
Updated

drm/amdgpu/vcn4: Prevent OOB reads when parsing IB

Affected Software

15 affected componentsFixes available
Linux Linux kernel (amdgpu vcn4)
Microsoft azl3 kernel 6.6.139.1-1<6.6.141.1-1
6.6.141.1-1
Linux Linux kernel>=6.0<6.6.140
Linux Linux kernel>=6.7<6.12.90
Linux Linux kernel>=6.13<6.18.32
Linux Linux kernel>=6.19<7.0.9
debian/linux*
debian/linux<6.12.90-1
6.12.90-1
debian/linux<7.0.9-1
7.0.9-1
linux/kernel>=6.0.0<6.1.191
6.1.191
linux/kernel>=6.2.0<6.6.140
6.6.140
linux/kernel>=6.7.0<6.12.90
6.12.90
linux/kernel>=6.13.0<6.18.32
6.18.32
linux/kernel>=6.19.0<7.0.9
7.0.9
debian/linux<=6.1.176-1, <=6.1.190-1
6.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 6.6.141.1-1
  2. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.1.191
  3. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.6.140
  4. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.12.90
  5. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.18.32
  6. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 7.0.9
  7. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.12.90-1
  8. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 7.0.9-1
  9. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.14-1
  10. Compensating control

    Rewrite the drm/amdgpu VCN4 IB parsing to use amdgpu_ib_get_value(), which performs bounds checks and prevents out-of-bounds reads.

Event History

May 28, 2026
CVE Published
via MITRE·09:40 AM
Data Sourced
via MITRE·09:40 AM
DescriptionSeverity
Data Sourced
via OSV·09:40 AM
DescriptionSeverityAffected Software
Data Sourced
via NVD·10:16 AM
RemedyDescriptionSeverityWeaknessAffected Software
May 29, 2026
Data Sourced
via Microsoft·08:07 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2026-46204?

The severity of CVE-2026-46204 is rated as high with a CVSS score of 7.1.

2

How do I fix CVE-2026-46204?

To fix CVE-2026-46204, ensure that your Linux kernel is updated to the latest version that includes the relevant patches for the amdgpu vcn4.

3

What type of vulnerability is CVE-2026-46204?

CVE-2026-46204 is an out-of-bounds read vulnerability in the Linux kernel related to the amdgpu graphics driver.

4

What impact does CVE-2026-46204 have on systems?

CVE-2026-46204 can potentially allow an attacker to read sensitive memory, leading to information disclosure.

5

Are there any exploit scenarios for CVE-2026-46204?

Exploitation of CVE-2026-46204 could occur in scenarios where unprivileged users can interact with the amdgpu driver, particularly in systems running vulnerable kernel versions.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203