CVE-2026-46626: SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APP_ENV/APP_DEBUG via parse_str/SAPI Argv Mismatch

Published May 20, 2026
·
Updated

CVE-2026-46626: SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APPENV/APPDEBUG via parsestr/SAPI Argv Mismatch

Affected Software

15 affected componentsFixes available
composer/symfony/symfony>=5.4.46, <5.4.52
5.4.52
composer/symfony/symfony>=6.4.14, <6.4.40
6.4.40
composer/symfony/symfony>=7.1.7, <7.2.0
composer/symfony/symfony>=7.2.0, <7.3.0
composer/symfony/symfony>=7.3.0, <7.4.0
composer/symfony/symfony>=7.4.0, <7.4.12
7.4.12
composer/symfony/symfony>=8.0.0, <8.0.12
8.0.12
composer/symfony/runtime>=5.4.46, <5.4.52
5.4.52
composer/symfony/runtime>=6.4.14, <6.4.40
6.4.40
composer/symfony/runtime>=7.1.7, <7.2.0
composer/symfony/runtime>=7.2.0, <7.3.0
composer/symfony/runtime>=7.3.0, <7.4.0
composer/symfony/runtime>=7.4.0, <7.4.12
7.4.12
composer/symfony/runtime>=8.0.0, <8.0.12
8.0.12
debian/symfony
5.4.53+dfsg-0+deb12u16.4.41+dfsg-0+deb13u16.4.49+dfsg-0+deb13u17.4.22+dfsg-17.4.23+dfsg-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 5.4.52
  2. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 6.4.40
  3. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 7.4.12
  4. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 8.0.12
  5. Upgrade

    Upgrade composer/symfony/runtime to a version that resolves this vulnerability.

    Fixed in 5.4.52
  6. Upgrade

    Upgrade composer/symfony/runtime to a version that resolves this vulnerability.

    Fixed in 6.4.40
  7. Upgrade

    Upgrade composer/symfony/runtime to a version that resolves this vulnerability.

    Fixed in 7.4.12
  8. Upgrade

    Upgrade composer/symfony/runtime to a version that resolves this vulnerability.

    Fixed in 8.0.12
  9. Upgrade

    Upgrade debian/symfony to a version that resolves this vulnerability.

    Fixed in 5.4.53+dfsg-0+deb12u1Fixed in 6.4.41+dfsg-0+deb13u1Fixed in 6.4.49+dfsg-0+deb13u1Fixed in 7.4.22+dfsg-1Fixed in 7.4.23+dfsg-1

Event History

May 20, 2026
Advisory Published
via Packagist·08:00 AM
Data Sourced
via Packagist·08:00 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203