CVE-2026-5406: Uncontrolled Recursion in Wireshark
FC-SWILS protocol dissector crash in Wireshark 4.6.0 to 4.6.4 and 4.4.0 to 4.4.14 allows denial of service
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Wiresharkto a version that resolves this vulnerability.Fixed in 4.6.5
Event History
Frequently Asked Questions
What is the severity of CVE-2026-5406?
CVE-2026-5406 is classified as a denial of service vulnerability due to uncontrolled recursion in the Wireshark FC-SWILS protocol dissector.
How do I fix CVE-2026-5406?
To fix CVE-2026-5406, upgrade Wireshark to version 4.6.5 or later if you are using versions 4.6.0 to 4.6.4, or upgrade to version 4.4.15 or later if you are using versions 4.4.0 to 4.4.14.
What versions of Wireshark are affected by CVE-2026-5406?
CVE-2026-5406 affects Wireshark versions 4.6.0 to 4.6.4 and 4.4.0 to 4.4.14.
Can CVE-2026-5406 be exploited remotely?
Yes, CVE-2026-5406 can be exploited remotely, allowing an attacker to cause a denial of service.
What is the impact of CVE-2026-5406?
The impact of CVE-2026-5406 is a crash of Wireshark, leading to denial of service for users.