CVE-2026-56848: Re-entrant `nghttp2_session_mem_send()` during `nghttp2_session_mem_recv()` causes heap-use-after-free in Node.js HTTP/2

Published Jul 29, 2026
·
Updated

A flaw in Node.js HTTP/2 handling allows nghttp2sessionmemsend() to be called re-entrantly while nghttp2sessionmemrecv() is executing, resulting in a heap-use-after-free.

This vulnerability affects Node.js 26.x, 24.x, and 22.x.

Other sources

A flaw in Node.js HTTP/2 handling allows nghttp2sessionmemsend() to be called re-entrantly while nghttp2sessionmemrecv() is executing, resulting in a heap-use-after-free.

— Node.Js

Affected Software

10 affected componentsFixes available
Node.js>=22.0.0<=22.x, >=24.0.0<=24.x, >=26.0.0<=26.x
Node.js Node.js>=22.0.0<22.23.2, >=24.0.0<24.18.1, >=26.0.0<26.5.1
22.23.224.18.126.5.1
Node.js Node.js>=22.0.0<22.23.2
22.23.2
Node.js Node.js>=24.0.0<24.18.1
24.18.1
Node.js Node.js>=26.0.0<26.5.1
26.5.1
alpine/nodejs<22.23.2-r0
22.23.2-r0
alpine/nodejs<22.23.2-r0
22.23.2-r0
alpine/nodejs<24.18.1-r0
24.18.1-r0
alpine/nodejs<24.18.1-r0
24.18.1-r0
alpine/nodejs-current<26.5.1-r0
26.5.1-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 22.23.2Fixed in 24.18.1Fixed in 26.5.1
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 22.23.2
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 24.18.1
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 26.5.1
  5. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 22.23.2-r0
  6. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 24.18.1-r0
  7. Upgrade

    Upgrade alpine/nodejs-current to a version that resolves this vulnerability.

    Fixed in 26.5.1-r0

Event History

Jul 29, 2026
CVE Published
via Node.js·12:00 AM
Data Sourced
via Node.js·12:00 AM
DescriptionSeverityAffected Software
Aug 4, 2026
CVE Published
via MITRE·03:57 PM
Data Sourced
via MITRE·03:57 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·05:16 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·05:16 PM
DescriptionSeverityAffected Software
Aug 19, 2026
Exploit Published
via GitHub·04:13 AM

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2026-56848?

The severity of CVE-2026-56848 is rated high with a score of 7.5.

2

How do I fix CVE-2026-56848?

To fix CVE-2026-56848, upgrade Node.js to a version not affected by this vulnerability.

3

What impact does CVE-2026-56848 have?

CVE-2026-56848 can lead to a heap-use-after-free condition, which can cause application crashes.

4

Which Node.js versions are affected by CVE-2026-56848?

CVE-2026-56848 affects Node.js versions 26.x, 24.x, and 22.x.

5

What kind of vulnerability is CVE-2026-56848?

CVE-2026-56848 is categorized under the use after free vulnerability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203