CVE-2026-57185: Asterisk: Buffer over-read in Asterisk PJSIP MWI body parser

Published Oct 27, 2026
·
Updated

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may crash Asterisk through a buffer over-read in the PJSIP MWI body parser by sending a carefully crafted SIP NOTIFY request. The attacker must pass SIP authentication using either a username/password or source IP address matching. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Affected Software

2 affected components
Asterisk Asterisk<20.20.1, <21.12.3, <22.10.1, <23.4.1
Asterisk Certified Asterisk<20.7-cert11, <22.8-cert3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 20.20.1
  2. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 21.12.3
  3. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 22.10.1
  4. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 23.4.1
  5. Upgrade

    Upgrade Certified Asterisk to a version that resolves this vulnerability.

    Fixed in 20.7-cert11
  6. Upgrade

    Upgrade Certified Asterisk to a version that resolves this vulnerability.

    Fixed in 22.8-cert3

Event History

Oct 27, 2026
CVE Published
via MITRE·04:40 PM
Data Sourced
via MITRE·04:40 PM
DescriptionSeverityWeakness

Frequently Asked Questions

1

Who can exploit this issue?

An attacker must be able to authenticate to the affected Asterisk SIP service. Authentication can be satisfied with a username and password or by connecting from a source IP address that matches an allowed configuration.

2

What is the practical impact of successful exploitation?

A successful attack can crash Asterisk, causing a denial of service. The provided information does not indicate confidentiality or integrity impact.

3

Which releases contain the fix?

The issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, and 23.4.1. It is also fixed in Certified Asterisk 20.7-cert11 and 22.8-cert3.

4

What should be prioritized if an immediate upgrade is not possible?

Restrict SIP authentication access to trusted users and source IP addresses, since exploitation requires passing SIP authentication. Review configurations that permit authentication based on source IP address matching and limit those allowed addresses as tightly as possible.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203