CVE-2026-57188: Asterisk: Stack buffer overflow in res_xmpp XMPP namespace prefix handling

Published Oct 27, 2026
·
Updated

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may cause a stack buffer overflow in resxmpp XMPP namespace prefix handling using carefully crafted packets. The resxmpp module must be loaded, an XMPP connection must be configured in xmpp.conf, and the attacker must have an XMPP account on the same or a federated server. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Affected Software

2 affected components
Asterisk Asterisk<20.20.1, <21.12.3, <22.10.1, <23.4.1
Asterisk Certified Asterisk<20.7-cert11, <22.8-cert3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 20.20.1
  2. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 21.12.3
  3. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 22.10.1
  4. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 23.4.1
  5. Upgrade

    Upgrade Certified Asterisk to a version that resolves this vulnerability.

    Fixed in 20.7-cert11
  6. Upgrade

    Upgrade Certified Asterisk to a version that resolves this vulnerability.

    Fixed in 22.8-cert3

Event History

Oct 27, 2026
CVE Published
via MITRE·05:55 PM
Data Sourced
via MITRE·05:55 PM
DescriptionWeakness
Data Sourced
via NVD·06:17 PM
DescriptionSeverityWeakness

Frequently Asked Questions

1

Which deployments are exposed to this issue?

A deployment is exposed only if the res_xmpp module is loaded and an XMPP connection is configured in xmpp.conf. Systems without that module loaded or without an XMPP connection configured do not meet the stated exposure conditions.

2

What access does an attacker need?

The attacker must be authenticated and have an XMPP account on the same XMPP server or on a federated server. Exploitation requires sending carefully crafted XMPP packets.

3

What versions contain the fix?

The issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, and 23.4.1. It is also fixed in Certified Asterisk 20.7-cert11 and 22.8-cert3.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203